Engineering Papers⌕ Search

SEARCH · Engineering Papers

Results for “compression rate”

Search indexed NASA NTRS and DOE OSTI research on propulsion, heat transfer, battery materials and energy systems. Follow report and document links to the original sources.

Quote a phrase for an exact phrase match. Source license links do not imply unrestricted reuse.

At least 163 records · Page 9

Shear failure and impact resistance in graphite fiber laminates

The multispan beam (MSB) test was evaluated as a predictor of damage resistance and damage tolerance in quasi-isotropic graphite laminates. Materials studied were five commercial prepreg system using high-strain and intermediate-modulus carbon fibers, as well as an amorphous thermoplastic system. Failure loads and displacements in the MSB tests showed little rate dependence. Values of compressive strength after a standard low-velocity impact correlated fairly well with the MSB results.

Srinivasan, Krishna↗

Some Practical Universal Noiseless Coding Techniques

Report discusses noiseless data-compression-coding algorithms, performance characteristics and practical consideration in implementation of algorithms in coding modules composed of very-large-scale integrated circuits. Report also has value as tutorial document on data-compression-coding concepts. Coding techniques and concepts in question "universal" in sense that, in principle, applicable to streams of data from variety of sources. However, discussion oriented toward compression of high-rate data generated by spaceborne sensors for lower-rate transmission back to earth.

Rice, Robert F.↗

Compression of multispectral Landsat imagery using the Embedded Zerotree Wavelet (EZW) algorithm

The Embedded Zerotree Wavelet (EZW) algorithm has proven to be an extremely efficient and flexible compression algorithm for low bit rate image coding. The embedding algorithm attempts to order the bits in the bit stream in numerical importance and thus a given code contains all lower rate encodings of the same algorithm. Therefore, precise bit rate control is achievable and a target rate or distortion metric can be met exactly. Furthermore, the technique is fully image adaptive. An algorithm for multispectral image compression which combines the spectral redundancy removal properties of the image-dependent Karhunen-Loeve Transform (KLT) with the efficiency, controllability, and adaptivity of the embedded zerotree wavelet algorithm is presented. Results are shown which illustrate the advantage of jointly encoding spectral components using the KLT and EZW.

Shapiro, Jerome M.↗

Thermal/Pyrolysis Gas Flow Analysis of Carbon Phenolic Material

Provided in this study are predicted in-depth temperature and pyrolysis gas pressure distributions for carbon phenolic materials that are externally heated with a laser source. Governing equations, numerical techniques and comparisons to measured temperature data are also presented. Surface thermochemical conditions were determined using the Aerotherm Chemical Equilibrium (ACE) program. Surface heating simulation used facility calibrated radiative and convective flux levels. Temperatures and pyrolysis gas pressures are predicted using an upgraded form of the SINDA/CMA program that was developed by NASA during the Solid Propulsion Integrity Program (SPIP). Multispecie mass balance, tracking of condensable vapors, high heat rate kinetics, real gas compressibility and reduced mixture viscosity's have been added to the algorithm. In general, surface and in-depth temperature comparisons are very good. Specie partial pressures calculations show that a saturated water-vapor mixture is the main contributor to peak in-depth total pressure. Further, for most of the cases studied, the water-vapor mixture is driven near the critical point and is believed to significantly increase the local heat capacity of the composite material. This phenomenon if not accounted for in analysis models may lead to an over prediction in temperature response in charring regions of the material.

Clayton, J. Louie↗

Chemical, Physical, and Mechanical Characterization of Isocyanate Cross-linked Amine-Modified Silica Aerogels

We describe a new mechanically strong lightweight porous composite material obtained by encapsulating the skeletal framework of amine-modified silica aerogels with polyurea. The conformal polymer coating preserves the mesoporous structure of the underlying silica framework and the thermal conductivity remains low at 0.041 plus or minus 0.001 W m(sup -1 K(sup -1). The potential of the new cross-linked silica aerogels for load-carrying applications was determined through characterization of their mechanical behavior under compression, three-point bending, and dynamic mechanical analysis (DMA). A primary glass transition temperature of 130 C was identified through DMA. At room temperature, results indicate a hyperfoam behavior where in compression cross-linked aerogels are linearly elastic under small strains (less than 4%) and then exhibit yield behavior (until 40% strain), followed by densification and inelastic hardening. At room temperature the compressive Young's modulus and the Poisson's ratio were determined to be 129 plus or minus 8 MPa and 0.18, respectively, while the strain at ultimate failure is 77% and the average specific compressive stress at ultimate failure is 3.89 x 10(exp 5) N m kg(sup -1). The specific flexural strength is 2.16 x 10(exp 4) N m kg(sup -1). Effects on the compressive behavior of strain rate and low temperature were also evaluated.

Katti, Atul↗

Capabilities and History of NASA Marshall Space Flight Center's Hydrogen Test Facility

The Hydrogen Test Facility (HTF) has conducted mechanical testing for aerospace materials at NASA's Marshall Space Flight Center for many years. One of the first facilities of its kind to run high-pressure cryogenic permeability tests in liquid hydrogen, HTF is now characterized as a unique national resource capable of overcoming hazardous conditions to perform tests directly in various hydrogen environments. At HTF, custom test systems are operated in eight structurally reinforced test cells from 0 to 68,948 kPa (0 to 10,000 psi) at -253 to 982 C (--423 to 1800 F) in hydrogen, air, helium, and nitrogen, with other environments available upon request. Standard mechanical procedures include compression, fatigue crack growth rate, four-point bend, high/low cycle fatigue, fracture toughness, shear, strain-to-crack, and tensile testing. Cryogenic permeability and thermal conductivity and gaseous creep testing are offered, as well as simulated service under different combinations of operating environment(s), stress, pressure, and ambient-to-extreme temperatures. Advanced tests are routinely developed upon demand, and special component testing is also available. Current efforts include the renovation of two high-pressure gaseous test cells to generate data for a J-2X engine designed for Constellation's Ares I and V vehicles. In the past, HTF has supported other critical NASA programs, such as Apollo, Space Shuttle, and Next Generation Launch Technologies. During the 1990's, hundreds of tests were conducted in liquid hydrogen and liquid nitrogen during development of the Space Shuttle's super lightweight tank, which provided the thrust required to achieve low Earth orbit for the International Space Station. This facility was designed and built in 1963. Originally called the Low Temperature Test Facility, it became known as the Cryogenic Test Facility in the late 1980's and HTF in the early 1990's.

Malone, T. W.↗

Validation of Cryogenic Propellant Tank Filling using Computational Fluid Dynamics Simulation

Validation of cryogenic propellant tank filling was performed using the Computational Fluid Dynamics (CFD) solver Loci/STREAM-VoF. The validation effort helped identify modeling methodologies that enable NASA to best support its partners in both launch pad and on-orbit filling operations. Data from liquid hydrogen ground tests filled via jet injection were used for the validation effort which include a sensitivity to initial tank wall temperature. Initially hot walls are expected to yield rapid evaporation and possibly boiling. A Volume of Fluid (VoF) methodology was used to capture the gas-liquid interface. Rapid breakup of the liquid jet was observed in simulation results as liquid evaporated and expanded. Inflowing liquid transitioned to a contiguous jet as tank temperatures decreased, gas pressure increased, and saturation conditions at the incoming liquid temperature were approached. The final phase of filling was distinguished by rapid gas pressure rise due to a higher rate of gas volume compression than condensation at the liquid surface. Key physics of propellant tank filling were captured in the computational predictions, and opportunities for added simulation robustness and efficiency in future modeling efforts were identified.

CFM↗

Survey of Header Compression Techniques

This report provides a summary of several different header compression techniques. The different techniques included are: (1) Van Jacobson's header compression (RFC 1144); (2) SCPS (Space Communications Protocol Standards) header compression (SCPS-TP, SCPS-NP); (3) Robust header compression (ROHC); and (4) The header compression techniques in RFC2507 and RFC2508. The methodology for compression and error correction for these schemes are described in the remainder of this document. All of the header compression schemes support compression over simplex links, provided that the end receiver has some means of sending data back to the sender. However, if that return path does not exist, then neither Van Jacobson's nor SCPS can be used, since both rely on TCP (Transmission Control Protocol). In addition, under link conditions of low delay and low error, all of the schemes perform as expected. However, based on the methodology of the schemes, each scheme is likely to behave differently as conditions degrade. Van Jacobson's header compression relies heavily on the TCP retransmission timer and would suffer an increase in loss propagation should the link possess a high delay and/or bit error rate (BER). The SCPS header compression scheme protects against high delay environments by avoiding delta encoding between packets. Thus, loss propagation is avoided. However, SCPS is still affected by an increased BER (bit-error-rate) since the lack of delta encoding results in larger header sizes. Next, the schemes found in RFC2507 and RFC2508 perform well for non-TCP connections in poor conditions. RFC2507 performance with TCP connections is improved by various techniques over Van Jacobson's, but still suffers a performance hit with poor link properties. Also, RFC2507 offers the ability to send TCP data without delta encoding, similar to what SCPS offers. ROHC is similar to the previous two schemes, but adds additional CRCs (cyclic redundancy check) into headers and improves compression schemes which provide better tolerances in conditions with a high BER.

Ishac, Joseph↗

Data compression applied to HHVT

A task order was written by the High Resolution, High Frame Rate Video Technology (HHVT) project engineers to study data compression techniques that could be applied to the HHVT system. Specifically, the goals of the HHVT data compression study are to accomplish the following: (1) Determine the downlink capabilities of the Space Shuttle and Space Station Freedom to support HHVT data (i.e., determine the maximum data rates and link availability); (2) Determine current and projected capabilities of high speed storage media to support HHVT data by determining their maximum data acquisition/transmission rates and volumes; (3) Identify which experiment in the HHVT Users' Requirement data base need data compression, based on the experiments' imaging requirements; (4) Select the best data compression technique for each of these users by identifying a technique that provides compression but minimizes distortion; and (5) Investigate state-of-the-art technologies for possible implementation of selected data compression techniques. Data compression will be needed because of the high data rates and larger volumes of data that will result from the use of digitized video onboard the Space Shuttle and Space Station Freedom.

Thompson, William K.↗

A simple application of the Bailey-Orowan creep model to Fe-39.8 at. pct Al and gamma/gamma prime - alpha

The results of a study to determine the recovery rates and work-hardening coefficients for creep from constant cross-head speed compressive tests are presented. Stressing and straining rates are computed from measured time-load curves obtained from compression testing between 1200 and 1400 K of several B2 crystal structure Fe-39.8 Al intermetallic materials and the directionally solidified eutectic alloy gamma/gamma prime alpha. These quantities are then fitted to the universal form of the Bailey-Orowan equation for creep. The recovery rates were found to be functions of nominal strain rate, stress, and temperature, while the hardening coefficients were dependent only on temperature. While the work-hardening coefficient for gamma/gamma prime - alpha was about 0.05 of the elastic modulus, the work-hardening coefficients for Fe-39.8 at. pct Al were less than 0.002 of the modulus.

Whittenberger, J. D.↗

Image Data Compression Having Minimum Perceptual Error

A method is presented for performing color or grayscale image compression that eliminates redundant and invisible image components. The image compression uses a Discrete Cosine Transform (DCT) and each DCT coefficient yielded by the transform is quantized by an entry in a quantization matrix which determines the perceived image quality and the bit rate of the image being compressed. The quantization matrix comprises visual masking by luminance and contrast technique all resulting in a minimum perceptual error for any given bit rate, or minimum bit rate for a given perceptual error.

Watson, Andrew B.↗

Image-adapted visually weighted quantization matrices for digital image compression

A method for performing image compression that eliminates redundant and invisible image components is presented. The image compression uses a Discrete Cosine Transform (DCT) and each DCT coefficient yielded by the transform is quantized by an entry in a quantization matrix which determines the perceived image quality and the bit rate of the image being compressed. The present invention adapts or customizes the quantization matrix to the image being compressed. The quantization matrix comprises visual masking by luminance and contrast techniques and by an error pooling technique all resulting in a minimum perceptual error for any given bit rate, or minimum bit rate for a given perceptual error.

Watson, Andrew B.↗

Image data compression having minimum perceptual error

A method for performing image compression that eliminates redundant and invisible image components is described. The image compression uses a Discrete Cosine Transform (DCT) and each DCT coefficient yielded by the transform is quantized by an entry in a quantization matrix which determines the perceived image quality and the bit rate of the image being compressed. The present invention adapts or customizes the quantization matrix to the image being compressed. The quantization matrix comprises visual masking by luminance and contrast techniques and by an error pooling technique all resulting in a minimum perceptual error for any given bit rate, or minimum bit rate for a given perceptual error.

Watson, Andrew B.↗

Mechanical Behavior of Gamma-Met PX under Uniaxial Loading at Elevated Temperatures and High Strain Rates

Gamma titanium aluminides have received considerable attention over the last decade. These alloys are known to have low density, good high temperature strength retention and good oxidation and corrosion resistance. However, poor ductility and low fracture toughness have been the key limiting factors in the full utilization of these alloys. More recently, a new generation of gamma titanium aluminide alloys, commonly referred to as Gamma-met PX, has been developed by GKSS, Germany. These alloys have been observed to have superior strength and better oxidation resistance at elevated temperatures when compared with conventional gamma titanium aluminides. The present paper discusses results of a study to understand the uniaxial mechanical behavior in both compression and tension of Gamma-Met PX at elevated temperatures and high strain rates. The compression and tensile tests are conducted using a modified split-Hopkinson bar apparatus at test temperatures ranging from room temperature to 900 C and strain rates of up to 3500/s. Under uniaxial compression, in the temperature range from room to 600 C, the flow stress is observed to be nearly independent of test temperature. However, at temperatures higher than 600 C thermal softening is observed at all strain rates with the rate of thermal softening increasing dramatically between 800 C and 900 C. The room temperature tensile tests show negligible strain-rate dependence on both yield stress and flow stress. With an increase in test temperature from room to 900 C the material shows a drop in both yield and flow stress at all levels of plastic strain. However, the measured flow stress is still higher when compared to nickel based super-alloys and other gamma titanium aluminides under similar test conditions. Also, no anomaly in yield stress is observed up to 900 C.

Shazly, Mostafa↗

Design of source coders and joint source/channel coders for noisy channels

A theory behind a proposed joint source/channel coding approach is developed and a variable rate design approach which provides substantial improvement over current joint source/channel coder designs is obtained. The Rice algorithm as applied to the output of the Gamma Ray Detector of the Mars Orbiter is evaluated. An alternative algorithm is obtained which outperforms the Rice both in terms of data compression and noisy channel performance. A high-fidelity low-rate image compression algorithm is developed which provides almost distortionless compression of high resolution images.

Sayood, Khalid↗

RPV application of a globally adaptive rate controlled compressor

A globally adaptive image compression structure is introduced for use in a tactical RPV environment. The structure described would provide an operator with the flexibility to dynamically maximize the usefulness of a limited and changing data rate. The concepts would potentially simplify system design while at the same time improving overall system performance.

Rice, R. F.↗

Comparison of video fields and frames for transform compression

Because of the interlaced television scan, the two fields that form an interlaced video frame are generated 1/60 of a second apart. If the two fields are compressed independently, the correlation between adjacent lines is unused. The transmission rate can be reduced by using a field memory to form an interlaced frame. Four test images were processed as fields and as interlaced frames, using both theoretical and experimental compression designs. For comparable mean-square error and subjective appearance, field compression requires about one-half bit per sample more than frame compression. However, the overall transmission rate - the number of bits per image times the number of images per second - is more meaningful than the number of bits per sample. When transform compression at low transmission rates merges the adjacent lines, frame compression becomes similar to field repeating, and the memory can be reduced.

Jones, H. W., Jr.↗