Engineering Papers⌕ Search

SEARCH · Engineering Papers

Results for “bit error”

Search indexed NASA NTRS and DOE OSTI research on propulsion, heat transfer, battery materials and energy systems. Follow report and document links to the original sources.

Quote a phrase for an exact phrase match. Source license links do not imply unrestricted reuse.

At least 127 records · Page 7

Data Transfer Efficiency Over Satellite Circuits Using a Multi-Socket Extension to the File Transfer Protocol (FTP)

In several experiments using NASA's Advanced Communications Technology Satellite (ACTS), investigators have reported disappointing throughput using the transmission control protocol/Internet protocol (TCP/IP) protocol suite over 1.536Mbit/sec (T1) satellite circuits. A detailed analysis of file transfer protocol (FTP) file transfers reveals that both the TCP window size and the TCP 'slow starter' algorithm contribute to the observed limits in throughput. In this paper we summarize the experimental and and theoretical analysis of the throughput limit imposed by TCP on the satellite circuit. We then discuss in detail the implementation of a multi-socket FTP, XFTP client and server. XFTP has been tested using the ACTS system. Finally, we discuss a preliminary set of tests on a link with non-zero bit error rates. XFTP shows promising performance under these conditions, suggesting the possibility that a multi-socket application may be less effected by bit errors than a single, large-window TCP connection.

Allman, Mark↗

EFQPSK Versus CERN: A Comparative Study

This report presents a comparative study on Enhanced Feher's Quadrature Phase Shift Keying (EFQPSK) and Constrained Envelope Root Nyquist (CERN) techniques. These two techniques have been developed in recent times to provide high spectral and power efficiencies under nonlinear amplifier environment. The purpose of this study is to gain insights into these techniques and to help system planners and designers with an appropriate set of guidelines for using these techniques. The comparative study presented in this report relies on effective simulation models and procedures. Therefore, a significant part of this report is devoted to understanding the mathematical and simulation models of the techniques and their set-up procedures. In particular, mathematical models of EFQPSK and CERN, effects of the sampling rate in discrete time signal representation, and modeling of nonlinear amplifiers and predistorters have been considered in detail. The results of this study show that both EFQPSK and CERN signals provide spectrally efficient communications compared to filtered conventional linear modulation techniques when a nonlinear power amplifier is used. However, there are important differences. The spectral efficiency of CERN signals, with a small amount of input backoff, is significantly better than that of EFQPSK signals if the nonlinear amplifier is an ideal clipper. However, to achieve such spectral efficiencies with a practical nonlinear amplifier, CERN processing requires a predistorter which effectively translates the amplifier's characteristics close to those of an ideal clipper. Thus, the spectral performance of CERN signals strongly depends on the predistorter. EFQPSK signals, on the other hand, do not need such predistorters since their spectra are almost unaffected by the nonlinear amplifier, Ibis report discusses several receiver structures for EFQPSK signals. It is observed that optimal receiver structures can be realized for both coded and uncoded EFQPSK signals with not too much increase in computational complexity. When a nonlinear amplifier is used, the bit error rate (BER) performance of the CERN signals with a matched filter receiver is found to be more than one decibel (dB) worse compared to the bit error performance of EFQPSK signals. Although channel coding is found to provide BER performance improvement for both EFQPSK and CERN signals, the performance of EFQPSK signals remains better than that of CERN. Optimal receiver structures for CERN signals with nonlinear equalization is left as a possible future work. Based on the numerical results, it is concluded that, in nonlinear channels, CERN processing leads towards better bandwidth efficiency with a compromise in power efficiency. Hence for bandwidth efficient communications needs, CERN is a good solution provided effective adaptive predistorters can be realized. On the other hand, EFQPSK signals provide a good power efficient solution with a compromise in band width efficiency.

Borah, Deva K.↗

Gaussian approximation versus nearly exact performance analysis of optical communication systems with PPM signaling and APD receivers

A 25-Mb/s direct-detection optical communication system that used Q = 4 PPM (pulse-position modulation) signaling was constructed and its performance measured under laboratory conditions. The system used a single-mode AlGaAs laser diode (lambda = 834 nm) and low-noise silicon avalanche photodiode (APD). A procedure for numerically computing system performance is given that uses the nearly exact Webb approximation of the true Conradi distribution for the APD output and does not require excessive amounts of computer time. Comparison revealed that modeling the APD ouptut as a Gaussian process under conditions of negligible background radiation and low (less than 10 to the -12 A) APD bulk leakage currents leads to substantial underestimates of optimal APD gain and overestimates of system bit error probability. Examples illustrate the breakdown of the Gaussian approximation in assessing system performance. The measured performance was in excellent agreement with that predicted by the computational procedure. The system achieved a bit error probability of 10 to the -6 at a received signal energy, corresponding to an average of 60 absorbed photons/bit and optimal APD gain of 700.

Davidson, Frederic M.↗

Performance of DPSK with convolutional encoding on time-varying fading channels

The bit error probability performance of a differentially-coherent phase-shift keyed (DPSK) modem with convolutional encoding and Viterbi decoding on time-varying fading channels is examined. Both the Rician and the lognormal channels are considered. Bit error probability upper bounds on fully-interleaved (zero-memory) fading channels are derived and substantiated by computer simulation. It is shown that the resulting coded system performance is a relatively insensitive function of the choice of channel model provided that the channel parameters are related according to the correspondence developed as part of this paper. Finally, a comparison of DPSK with a number of other modulation strategies is provided.

Mui, S. Y.↗

Survey of Header Compression Techniques

This report provides a summary of several different header compression techniques. The different techniques included are: (1) Van Jacobson's header compression (RFC 1144); (2) SCPS (Space Communications Protocol Standards) header compression (SCPS-TP, SCPS-NP); (3) Robust header compression (ROHC); and (4) The header compression techniques in RFC2507 and RFC2508. The methodology for compression and error correction for these schemes are described in the remainder of this document. All of the header compression schemes support compression over simplex links, provided that the end receiver has some means of sending data back to the sender. However, if that return path does not exist, then neither Van Jacobson's nor SCPS can be used, since both rely on TCP (Transmission Control Protocol). In addition, under link conditions of low delay and low error, all of the schemes perform as expected. However, based on the methodology of the schemes, each scheme is likely to behave differently as conditions degrade. Van Jacobson's header compression relies heavily on the TCP retransmission timer and would suffer an increase in loss propagation should the link possess a high delay and/or bit error rate (BER). The SCPS header compression scheme protects against high delay environments by avoiding delta encoding between packets. Thus, loss propagation is avoided. However, SCPS is still affected by an increased BER (bit-error-rate) since the lack of delta encoding results in larger header sizes. Next, the schemes found in RFC2507 and RFC2508 perform well for non-TCP connections in poor conditions. RFC2507 performance with TCP connections is improved by various techniques over Van Jacobson's, but still suffers a performance hit with poor link properties. Also, RFC2507 offers the ability to send TCP data without delta encoding, similar to what SCPS offers. ROHC is similar to the previous two schemes, but adds additional CRCs (cyclic redundancy check) into headers and improves compression schemes which provide better tolerances in conditions with a high BER.

Ishac, Joseph↗

Threshold detection in an on-off binary communications channel with atmospheric scintillation

The optimum detection threshold in an on-off binary optical communications system operating in the presence of atmospheric turbulence was investigated assuming a poisson detection process and log normal scintillation. The dependence of the probability of bit error on log amplitude variance and received signal strength was analyzed and semi-emperical relationships to predict the optimum detection threshold derived. On the basis of this analysis a piecewise linear model for an adaptive threshold detection system is presented. Bit error probabilities for non-optimum threshold detection system were also investigated.

Webb, W. E.↗

Threshold detection in an on-off binary communications channel with atmospheric scintillation

The optimum detection threshold in an on-off binary optical communications system operating in the presence of atmospheric turbulence was investigated assuming a poisson detection process and log normal scintillation. The dependence of the probability of bit error on log amplitude variance and received signal strength was analyzed and semi-empirical relationships to predict the optimum detection threshold derived. On the basis of this analysis a piecewise linear model for an adaptive threshold detection system is presented. The bit error probabilities for nonoptimum threshold detection systems were also investigated.

Webb, W. E.↗

Threshold detection in an on-off binary communications channel with atmospheric scintillation

The optimum detection threshold in an on-off binary optical communications system operating in the presence of atmospheric turbulence has been investigated assuming a Poisson detection process and log normal scintillation. The dependence of the probability of bit error on log amplitude variance and received signal strength has been analyzed, and semi-empirical relationships to predict the optimum detection threshold have been derived. On the basis of this analysis, a piecewise-linear model for an adaptive threshold detection system is presented. The bit-error probabilities for nonoptimum threshold detection systems have also been investigated.

Webb, W. E.↗

VHF command system study

Solutions are provided to specific problems arising in the GSFC VHF-PSK and VHF-FSK Command Systems in support of establishment and maintenance of Data Systems Standards. Signal structures which incorporate transmission on the uplink of a clock along with the PSK or FSK data are considered. Strategies are developed for allocating power between the clock and data, and spectral analyses are performed. Bit error probability and other probabilities pertinent to correct transmission of command messages are calculated. Biphase PCM/PM and PCM/FM are considered as candidate modulation techniques on the telemetry downlink, with application to command verification. Comparative performance of PCM/PM and PSK systems is given special attention, including implementation considerations. Gain in bit error performance due to coding is also considered.

Gee, T. H.↗

Adaptive box filters for removal of random noise from digital images

Adaptive box-filtering algorithms to remove random bit errors and to smooth noisy data have been developed. For both procedures, the standard deviation of those pixels within a local box surrounding each pixel is used. A series of two or three filters with decreasing box sizes can be run to clean up extremely noisy images and to remove bit errors near sharp edges. The second filter, for noise smoothing, is similar to the 'sigma filter' of Lee (1983). The technique effectively reduces speckle in radar images without eliminating fine details.

Eliason, Eric M.↗

Reception of Multiple Telemetry Signals via One Dish Antenna

A microwave aeronautical-telemetry receiver system includes an antenna comprising a seven-element planar array of receiving feed horns centered at the focal point of a paraboloidal dish reflector that is nominally aimed at a single aircraft or at multiple aircraft flying in formation. Through digital processing of the signals received by the seven feed horns, the system implements a method of enhanced cancellation of interference, such that it becomes possible to receive telemetry signals in the same frequency channel simultaneously from either or both of two aircraft at slightly different angular positions within the field of view of the antenna, even in the presence of multipath propagation. The present system is an advanced version of the system described in Spatio- Temporal Equalizer for a Receiving-Antenna Feed Array NPO-43077, NASA Tech Briefs, Vol. 34, No. 2 (February 2010), page 32. To recapitulate: The radio-frequency telemetry signals received by the seven elements of the array are digitized, converted to complex baseband form, and sent to a spatio-temporal equalizer that consists mostly of a bank of seven adaptive finite-impulse-response (FIR) filters (one for each element in the array) plus a unit that sums the outputs of the filters. The combination of the spatial diversity of the feedhorn array and the temporal diversity of the filter bank affords better multipath suppression performance than is achievable by means of temporal equalization alone. The FIR filter bank adapts itself in real time to enable reception of telemetry at a low bit error rate, even in the presence of frequency-selective multipath propagation like that commonly found at flight-test ranges. The combination of the array and the filter bank makes it possible to constructively add multipath incoming signals to the corresponding directly arriving signals, thereby enabling reductions in telemetry bit-error rates.

Mukai, Ryan↗

Simulation results for the Viterbi decoding algorithm

Concepts involved in determining the performance of coded digital communications systems are introduced. The basic concepts of convolutional encoding and decoding are summarized, and hardware implementations of sequential and maximum likelihood decoders are described briefly. Results of parametric studies of the Viterbi decoding algorithm are summarized. Bit error probability is chosen as the measure of performance and is calculated, by using digital computer simulations, for various encoder and decoder parameters. Results are presented for code rates of one-half and one-third, for constraint lengths of 4 to 8, for both hard-decision and soft-decision bit detectors, and for several important systematic and nonsystematic codes. The effect of decoder block length on bit error rate also is considered, so that a more complete estimate of the relationship between performance and decoder complexity can be made.

Batson, B. H.↗

High-order neural models for error correcting code

The decoding and error-correction of data transmitted over a noisy channel is in principle equivalent to the operation of a neural network performing as a content-addressable memory. For a successful application, however, the neural network has to be capable of storing arbitrary words, and it has to be guaranteed that the stored words represent the only stable attractors of the memory. This paper presents a novel high-order neural network architecture that has these characteristics. The analog nature of the network can be used to perform soft-decision decoding with any block code. The performance in terms of postdecoding bit error rate versus SNR is demonstrated for two exemplary block codes. The comparison with a conventional decoding algorithm for a (15,5) cyclic redundancy code shows, for example, that the bit error rate at 7dB SNR can be decreased by two orders of magnitude.

Jeffries, Clark↗

Simulated performance of coded PCM/FM modem on Rician fading channel

This paper describes a simulation approach to characterizing the performance of a coded PCM/FM modem operating on the classical Rician fading channel. In particular, we consider the performance of short constraint length convolutional codes in conjunction with Viterbi maximum likelihood decoding. The receiver consists of a narrowband filter followed by an ideal limiter/discriminator. Primary interest is in the bit error probability performance parameterized by both the fading channel and receiver parameters. Particular attention is given to simulating the impulse noise appearing at the discriminator output. This is the 'click' noise caused by encirclements of the origin by the instantaneous signal-plus-noise phasor. Results include the effects of channel memory and narrowband receiver filtering effects on overall bit error probability.

Modestino, J. W.↗

Response of a DRAM to single-ion tracks of different heavy-ion species and stopping powers

Multiple-bit errors caused by single-ion tracks in a 256-kb DRAM fabricated by a bulk process were observed for different ion species and stopping power values. The results demonstrate the utility of this device for the evaluation of ion-beam uniformity and ion-beam-induced charge collection in IC devices. The data indicate that single-ion-induced charge transport results in multiple-bit error clusters due to lateral diffusion of excess minority carriers (electrons). Charge collection occurred from a depth of up to 35 microns from the surface of the device. An apparent charge loss was observed for very heavy ions with a high stopping power (Au at 350 MeV).

Zoutendyk, J. A.↗

Optical communication with semiconductor laser diodes

A 25 megabit/sec direct detection optical communication system that used Q=4 PPM signalling was constructed and its performance measured under laboratory conditions. The system used a single-mode AlGaAs laser diode transmitter and low noise silicon avalanche photodiode (APD) photodetector. Comparison of measured performance with the theoretical revealed that modeling the APD output as a Gaussian process under conditions of negligible background radiation and low (less than 10 to the -12 power A) APD bulk leakage currents leads to substantial underestimates of optimal APD gain to use and overestimates of system bit error probability. A procedure is given to numerically compute system performance which uses the more accurate Webb's Approximation of the exact Conradi distribution for the APD ouput signal that does not require excessive amounts of computer time (a few minutes of VAX 8600 CPU time per system operating point). Examples are given which illustrate the breakdown of the Gaussian approximation in assessing system performance. This system achieved a bit error probability of 10 to the -6 power at a received signal energy corresponding to an average of 60 absorbed photons/bit and optimal APD gain of 700.

Davidson, F.↗

The effect of noisy carrier reference on telemetry with baseband arraying

Imperfect carrier reference causes a degradation in detection performance in coherent communication systems. A measure of this degradation is the radio loss, which is the amount of increase in data signal to noise ratio (SNR) per bit required to achieve the same bit error rate when carrier reference is perfect. Performance analysis and numerical results are obtained for the Voyager high rate telemetry link with maximum likelihood convolutional decoding. The arraying of antennas provides not only improved performance due to an increase in effective antenna aperture, but also a decrease in radio loss with respect to a single antenna. This telemetry link performance improvement is a function of the carrier loop SNR and data bit error rate. When the carrier loop SNR's are low, it provides a significant improvement in the telemetry link performance since the decrease in radio loss with respect to a single station is substantial.

Divsalar, D.↗

Spectral Re-Growth Reduction for CCSDS 8-D 8-PSK TCM

This report presents a study on the CCSDS recommended 8-dimensional 8 PSK Trellis Coded Modulation (TCM) scheme. The important steps of the CCSDS scheme include: conversion of serial data into parallel form, differential encoding, convolutional encoding, constellation mapping, and filtering the 8-PSK symbols using the square root raised cosine (SRRC) pulses. The last step, namely the filtering of the 8 PSK symbols using SRRC pulses, significantly affects the bandwidth of the signal. If a nonlinear power amplifier is used, the SRRC filtered signal creates spectral regrowth. The purpose of this report is to investigate a technique, called the smooth phase interpolated keying (SPIK), that can provide an alternative to SRRC filtering so that good spectral as well as power efficiencies can be obtained with the CCSDS encoder. The results of this study show that the CCSDS encoder does not affect the spectral shape of the SRRC filtered signal or the SPIK signal. When a nonlinear traveling wave tube amplifier (TWTA) is used, the spectral performance of the SRRC signal degrades significantly while the spectral performance of SPIK remains unaffected. The degrading effect of a nonlinear solid state power amplifier (SSPA) on SRRC is found to be less than that due to a nonlinear TWTA. However, in both cases, the spectral performance of the SRRC modulated signal is worse than that of the SPIK signal. The bit error rate (BER) performance of the SRRC signal in a linear amplifier environment is about 2.5 dB better than that of the SPIK signal when both the receivers use algorithms of similar complexity. In a nonlinear TWTA environment, the SRRC signal requires accurate phase tracking since the TWTA introduces additional phase distortion. This problem does not arise with SPIK signal due to its constant envelope property. When a nonlinear amplifier is used, the SRRC method loses nearly 1 dB in the bit error rate performance. The SPIK signal does not lose any performance. Thus the performance gap between SRRC and SPIK reduces. The BER performance of SPIK can be improved even further by using a more optimal receiver. A similar optimal receiver for SRRC is quite complex since the amplifier distorts the pulse shape. However, this requires further investigation and is not covered in this report.

Borah, Deva K.↗