Engineering Papers⌕ Search

SEARCH · Engineering Papers

Results for “error performance”

Search indexed NASA NTRS and DOE OSTI research on propulsion, heat transfer, battery materials and energy systems. Follow report and document links to the original sources.

Quote a phrase for an exact phrase match. Source license links do not imply unrestricted reuse.

At least 973 records · Page 54

On the probability of undetected error for the maximum distance separable codes

The performance of maximum-distance-separable codes with symbols from GF(1) when they are used for pure error detection or for simultaneous error correction and detection is investigated. These codes are good for symbol error detection. Their probability of undetected error is upper bounded by q to the -r and decreases monotonically as the symbol error probability epsilon decreases from (q-1)/q to 0, where r is the number of parity-check symbols of a code.

Kasami, T.↗

On the probability of undetected error for the maximum distance separable codes

The performance of maximum-distance-separable codes with symbols from GF(1) when they are used for pure error detection or for simultaneous error correction and detection is investigated. These codes are good for symbol error detection. Their probability of undetected error is upper bounded by q to the -r and decreases monotonically as the symbol error probability epsilon decreases from (q-1)/q to 0, where r is the number of parity-check symbols of a code.

Kasami, T.↗

Geospatial modeling of near subsurface temperatures of the contiguous United States for assessment of materials degradation

Abstract Understanding subsurface temperature variations is crucial for assessing material degradation in underground structures. This study maps subsurface temperatures across the contiguous United States for depths from 50 to 3500 m, comparing linear interpolation, gradient boosting (LightGBM), neural networks, and a novel hybrid approach combining linear interpolation with LightGBM. Results reveal heterogeneous temperature patterns both horizontally and vertically. The hybrid model performed best achieving a root mean square error of 2.61 °C at shallow depths (50–350 m). Model performance generally decreased with depth, highlighting challenges in deep temperature prediction. State-level analyses emphasized the importance of considering local geological factors. This study provides valuable insights for designing efficient underground facilities and infrastructure, underscoring the need for depth-specific and region-specific modeling approaches in subsurface temperature assessment.

Science & Technology - Other Topics↗

Stochastic response analysis, order reduction, and output feedback controllers for flexible spacecraft

Real disturbances and real sensors have finite bandwidths. The first objective of this paper is to incorporate this finiteness in the 'open-loop modal cost analysis' as applied to a flexible spacecraft. Analysis based on residue calculus shows that among other factors, significance of a mode depends on the power spectral density of disturbances and the response spectral density of sensors at the modal frequency. The second objective of this article is to compare performances of an optimal and a suboptimal output feedback controller, the latter based on 'minimum error excitation' of Kosut. Both the performances are found to be nearly the same, leading us to favor the latter technique because it entails only linear computations. Our final objective is to detect an instability due to truncated modes by representing them as a multiplicative and an additive perturbation in a nominal transfer function. In an example problem it is found that this procedure leads to a narrow range of permissible controller gains, and that it labels a wrong mode as a cause of instability. A free beam is used to illustrate the analysis in this work.

Hablani, H. B.↗

CATS-based Agents That Err

This report describes preliminary research on intelligent agents that make errors. Such agents are crucial to the development of novel agent-based techniques for assessing system safety. The agents extend an agent architecture derived from the Crew Activity Tracking System that has been used as the basis for air traffic controller agents. The report first reviews several error taxonomies. Next, it presents an overview of the air traffic controller agents, then details several mechanisms for causing the agents to err in realistic ways. The report presents a performance assessment of the error-generating agents, and identifies directions for further research. The research was supported by the System-Wide Accident Prevention element of the FAA/NASA Aviation Safety Program.

Callantine, Todd J.↗

An error criterion for determining sampling rates in closed-loop control systems

The determination of an error criterion which will give a sampling rate for adequate performance of linear, time-invariant closed-loop, discrete-data control systems was studied. The proper modelling of the closed-loop control system for characterization of the error behavior, and the determination of an absolute error definition for performance of the two commonly used holding devices are discussed. The definition of an adequate relative error criterion as a function of the sampling rate and the parameters characterizing the system is established along with the determination of sampling rates. The validity of the expressions for the sampling interval was confirmed by computer simulations. Their application solves the problem of making a first choice in the selection of sampling rates.

Brecher, S. M.↗

Stability-preserving Lossy Compression for Large-scale Partial Differential Equations

Checkpoint/Restart (C/R) strategies are vital for fault tolerance in PDE-based scientific simulations, yet traditional checkpointing incurs significant I/O overhead. Lossy compression offers a scalable solution by reducing checkpoint data size, but conventional methods often lack control over physical invariants (e.g., energy), leading to instability such as oscillations or divergence in Partial Differential Equations (PDE) systems. This paper introduces a stability-preserving compression approach tailored for PDE simulations by explicitly controlling kinetic and potential energy perturbations to ensure stable restarts. Extensive experiments conducted across diverse PDE configurations demonstrate that our method maintains numerical stability with minimal error magnification—even across multiple checkpoint-restart cycles—outperforming state-of-the-art lossy compressors. Parallel evaluations on the Frontier supercomputer show up to 8.4× improvement in checkpoint write performance and 6.3× in read performance, while maintaining relative L2 errors ∼ 2e-6 throughout continued simulation. These results provide practical guidance for balancing compression accuracy, stability, and computational efficiency in large-scale PDE applications.

Gong, Qian [ORNL] (ORCID:0000000235704142)↗

Survey of Header Compression Techniques

This report provides a summary of several different header compression techniques. The different techniques included are: (1) Van Jacobson's header compression (RFC 1144); (2) SCPS (Space Communications Protocol Standards) header compression (SCPS-TP, SCPS-NP); (3) Robust header compression (ROHC); and (4) The header compression techniques in RFC2507 and RFC2508. The methodology for compression and error correction for these schemes are described in the remainder of this document. All of the header compression schemes support compression over simplex links, provided that the end receiver has some means of sending data back to the sender. However, if that return path does not exist, then neither Van Jacobson's nor SCPS can be used, since both rely on TCP (Transmission Control Protocol). In addition, under link conditions of low delay and low error, all of the schemes perform as expected. However, based on the methodology of the schemes, each scheme is likely to behave differently as conditions degrade. Van Jacobson's header compression relies heavily on the TCP retransmission timer and would suffer an increase in loss propagation should the link possess a high delay and/or bit error rate (BER). The SCPS header compression scheme protects against high delay environments by avoiding delta encoding between packets. Thus, loss propagation is avoided. However, SCPS is still affected by an increased BER (bit-error-rate) since the lack of delta encoding results in larger header sizes. Next, the schemes found in RFC2507 and RFC2508 perform well for non-TCP connections in poor conditions. RFC2507 performance with TCP connections is improved by various techniques over Van Jacobson's, but still suffers a performance hit with poor link properties. Also, RFC2507 offers the ability to send TCP data without delta encoding, similar to what SCPS offers. ROHC is similar to the previous two schemes, but adds additional CRCs (cyclic redundancy check) into headers and improves compression schemes which provide better tolerances in conditions with a high BER.

Ishac, Joseph↗

Searching for the Most Harmful Field Errors in the HSR IR Superconducting Magnets

In this project, we improve beam stability for the Electron-Ion Collider. Magnetic field errors can reduce beam stability, making it essential to identify the field errors that have the greatest impact on accelerator performance. However, this is particularly challenging because beam stability depends on the complex interactions of many magnetic field errors, resulting in a high-dimensional and nonlinear optimization problem. We determine which field errors are the most influential for the large physical aperture superconducting magnet B2PF, a critical magnet in the Interaction Region (IR) in the Hadron Storage Ring (HSR). We complete and analyze nearly 30,000 simulations on the Brookhaven National Laboratory Linux Cluster by varying 18 nonlinear magnetic field errors. We evaluate beam stability using the dynamic aperture and the tune diffusion. We identify the field errors that most strongly influence beam stability and establish quantitative field error tolerances that improve accelerator performance.

43 PARTICLE ACCELERATORS↗

Modeling and Evaluating Pilot Performance in NextGen: Review of and Recommendations Regarding Pilot Modeling Efforts, Architectures, and Validation Studies

NextGen operations are associated with a variety of changes to the national airspace system (NAS) including changes to the allocation of roles and responsibilities among operators and automation, the use of new technologies and automation, additional information presented on the flight deck, and the entire concept of operations (ConOps). In the transition to NextGen airspace, aviation and air operations designers need to consider the implications of design or system changes on human performance and the potential for error. To ensure continued safety of the NAS, it will be necessary for researchers to evaluate design concepts and potential NextGen scenarios well before implementation. One approach for such evaluations is through human performance modeling. Human performance models (HPMs) provide effective tools for predicting and evaluating operator performance in systems. HPMs offer significant advantages over empirical, human-in-the-loop testing in that (1) they allow detailed analyses of systems that have not yet been built, (2) they offer great flexibility for extensive data collection, (3) they do not require experimental participants, and thus can offer cost and time savings. HPMs differ in their ability to predict performance and safety with NextGen procedures, equipment and ConOps. Models also vary in terms of how they approach human performance (e.g., some focus on cognitive processing, others focus on discrete tasks performed by a human, while others consider perceptual processes), and in terms of their associated validation efforts. The objectives of this research effort were to support the Federal Aviation Administration (FAA) in identifying HPMs that are appropriate for predicting pilot performance in NextGen operations, to provide guidance on how to evaluate the quality of different models, and to identify gaps in pilot performance modeling research, that could guide future research opportunities. This research effort is intended to help the FAA evaluate pilot modeling efforts and select the appropriate tools for future modeling efforts to predict pilot performance in NextGen operations.

pilot human performance models↗

LAF-Net: A Deep Residual and Cross-Attention Framework for Day-Ahead Load Forecasting: Preprint

Accurate day-ahead load forecasting is essential for reliable power system operations and market efficiency. System operators such as the Midcontinent Independent System Operator (MISO) rely on forecasts from multiple vendors, yet combining them effectively remains a persistent challenge due to vendor-specific biases. This paper presents a novel LSTM-Attention Fusion Network with Error Representation (LAF-Net) that enhances day-ahead hourly load forecasting through deep residual learning and multi-modal cross-attention. The proposed model builds a historical error memory from past vendor performance and dynamically queries it with future hour context to generate adaptive, hour-specific trust weights for each vendor. A bounded residual correction further refines forecasts by mitigating systematic and temporally localized errors. Tested on real MISO LBA data with multi-vendor forecasts, LAF-Net consistently outperforms the best vendor baseline across all 38 LBAs, achieving more than a 40% reduction in system-level mean absolute error (MAE) during peak load hours relative to the best vendor baseline.

24 POWER TRANSMISSION AND DISTRIBUTION↗

Error analysis of optical correlators

With the growing interest in using binary phase only filters (BPOF) in optical correlators that are implemented on magnetooptic spatial light modulators, an understanding of the effect of errors in system alignment and optical components is critical in obtaining optimal system performance. We present simulations of optical correlator performance degradation in the presence of eight errors. We break these eight errors into three groups: 1) alignment errors, 2) errors due to a combination of component imperfections and alignment errors, and 3) errors which result solely from non-ideal components. Under the first group, we simulate errors in the distance from the object to the first principle plane of the transform lens, the distance from the second principle plane of the transform lens to the filter plane, and rotational misalignment of the input mask with the filter mask. Next we consider errors which result from a combination of alignment and component imperfections. These include errors in the transform lens, the phase compensation lens, and the inverse Fourier transform lens. Lastly we have the component errors resulting from the choice of spatial light modulator. These include contrast error and phase errors caused by the non-uniform flatness of the masks. The effects of each individual error are discussed, and the result of combining all eight errors under assumptions of reasonable tolerances and system parameters is also presented. Conclusions are drawn as to which tolerances are most critical for optimal system performance.

Ma, Paul W.↗

Bayesian estimation - A sensitivity analysis

The robustness of the assigned prior distribution in a Bayesian estimation problem is examined. A Bayesian analysis for a stochastic intensity parameter of a Poisson distribution is summarized in which the natural conjugate is assigned as the prior distribution of the random parameter. The sensitivity analysis is carried out by assuming the existence of a true prior which is different in form from that of the assigned prior distribution. By using mean-squared error as a measure of performance, the ensuing Bayes decision function is compared to the corresponding minimum variance unbiased estimator. Results indicate that the Bayes estimator is largely robust to deviations from the assigned prior and remains squared-error superior to the MVU type within a broad region.

Canavos, G. C.↗

On the Robustness Properties of M-MRAC

The paper presents performance and robustness analysis of the modified reference model MRAC (model reference adaptive control) or M-MRAC in short, which differs from the conventional MRAC systems by feeding back the tracking error to the reference model. The tracking error feedback gain in concert with the adaptation rate provides an additional capability to regulate not only the transient performance of the tracking error, but also the transient performance of the control signal. This differs from the conventional MRAC systems, in which we have only the adaptation rate as a tool to regulate just the transient performance of the tracking error. It is shown that the selection of the feedback gain and the adaptation rate resolves the tradeoff between the robustness and performance in the sense that the increase in the feedback gain improves the behavior of the adaptive control signal, hence improves the systems robustness to time delays (or unmodeled dynamics), while increasing the adaptation rate improves the tracking performance or systems robustness to parametric uncertainties and external disturbances.

Stepanyan, Vahram↗

Mitigating Photon Jitter in Optical PPM Communication

A theoretical analysis of photon-arrival jitter in an optical pulse-position-modulation (PPM) communication channel has been performed, and now constitutes the basis of a methodology for designing receivers to compensate so that errors attributable to photon-arrival jitter would be minimized or nearly minimized. Photon-arrival jitter is an uncertainty in the estimated time of arrival of a photon relative to the boundaries of a PPM time slot. Photon-arrival jitter is attributable to two main causes: (1) receiver synchronization error [error in the receiver operation of partitioning time into PPM slots] and (2) random delay between the time of arrival of a photon at a detector and the generation, by the detector circuitry, of a pulse in response to the photon. For channels with sufficiently long time slots, photon-arrival jitter is negligible. However, as durations of PPM time slots are reduced in efforts to increase throughputs of optical PPM communication channels, photon-arrival jitter becomes a significant source of error, leading to significant degradation of performance if not taken into account in design. For the purpose of the analysis, a receiver was assumed to operate in a photon- starved regime, in which photon counts follow a Poisson distribution. The analysis included derivation of exact equations for symbol likelihoods in the presence of photon-arrival jitter. These equations describe what is well known in the art as a matched filter for a channel containing Gaussian noise. These equations would yield an optimum receiver if they could be implemented in practice. Because the exact equations may be too complex to implement in practice, approximations that would yield suboptimal receivers were also derived.

Moision, Bruce↗

A Non-Intrusive Optical (NIO) Method to Measure Optical Errors of in-situ Heliostats in Utility-Scale Power Tower Plants: Detecting Uncertainties in Heliostat Geometry

Heliostat optical errors can account for significant losses in efficiency of power tower concentrating solar power (CSP) plants. Accurately measuring heliostat optical errors can help to improve plant performance. A Non-Intrusive Optical (NIO) method has been developed to efficiently measure heliostat optical errors from UAS collected images of the mirror surface reflection [1]–[3]. In some cases, plant data of heliostat geometry can be incomplete or contain inaccuracies, in which case field collected data can be used to detect and correct uncertainties, which is valuable information for plant operators.

Mitchell, Rebecca↗

Better practices for inferring ecosystem water use strategy from eddy covariance data

Eddy covariance data are critical for inferring ecosystem water use strategies. Yet, such inferences are sensitive to a range of assumptions applied across studies, hindering our understanding of water use strategies within and across eddy covariance sites. A recent analysis across 151 FLUXNET2015 and AmeriFlux-FLUXNET datasets found that poor model performance was the key driver of non-robust inferences of ecosystem water use strategies. Here, we leverage this previous analysis to (i) identify the specific assumptions that improve inference model performance across most sites, (ii) explain the mechanisms behind the performance improvements, and (iii) check whether better performance improves water use inference. We find that the common practice of fitting a model to canopy conductance (G c ) derived from the evapotranspiration (ET) observations, rather than to observed ET itself, artificially amplifies data errors and degrades the model performance. Next, accounting for vegetation dynamics by applying a growing season filter or incorporating satellite LAI data improves performance, but the former practice may remove soil water stress periods. Lastly, using the leaf-to-air vapor pressure deficit (VPD l ) derived from ET observations as a model input may artificially inflate performance. Based on these results, we recommend selecting observed ET (rather than derived G c ) as the response variable, carefully accounting for vegetation dynamics, and avoiding derived VPD l as a model input; these best practices improve model performance by c. 20% and robustness by c. 80% across all eddy covariance sites. Nevertheless, the performance improvements do not always correspond to more robust inference of water use strategies, as model parameter selection and surface energy budget closure corrections still strongly influence the ecosystem water use parameter estimation in a site-specific manner.

AmeriFlux↗