Engineering Papers⌕ Search

SEARCH · Engineering Papers

Results for “error performance”

Search indexed NASA NTRS and DOE OSTI research on propulsion, heat transfer, battery materials and energy systems. Follow report and document links to the original sources.

Quote a phrase for an exact phrase match. Source license links do not imply unrestricted reuse.

At least 811 records · Page 45

Airborne navigation system performance during RNAV/MLS transition

Aircraft position error sensitivity to sensor errors and flight path geometry is analyzed during RNAV/MLS transition using a digital computer simulation. The avionics sensitivity data provides information necessary to establish requirements for additional guidance law design and to establish airspace requirements for maneuvering to null out any residual RNAV errors upon MLS transition. The data base is also beneficial as planning information for subsequent flight testing. The parameters varied during the generation of the data base include flight profile, error source content and magnitude, ground facility location, runway/flight path orientation and navigation mode. The avionics, autopilots and aircraft dynamics correspond to the existing NASA Terminal Configured Vehicle. Significant transients were observed during MLS transition, primarily in the vertical channel. These transients have a significant impact on airspace requirements and operational procedures in the RNAV/MLS environment.

Heine, W.↗

Parameter trade-offs for imaging spectroscopy systems

With the advent of the EOS era and of configurable sensors, users of these instruments are faced with the twin problems of specifying data acquisition parameters and extracting desired information from the voluminous data. An application of a system model is made to explore system parameter trade-offs for a model sensor based on the High Resolution Imaging Spectrometer. Radiometric performance was studied, along with the effect on classification accuracy of several system parameters. Using a model scene based on typical agricultural reflectance and atmospheric conditions, the atmosphere and sensor are seen to have significant effects on the mean received signal and noise performance. The effect of random uncorrelated errors in the radiometric calibration of the detector array is seen to degrade system performance, especially in the spectral bands below 1 micron. Accurate pixel-to-pixel relative radiometric calibration and the use of the Image Motion Compensation option are seen to improve classification accuracy, especially at high solar zenith angles. Feature sets chosen from characteristics of the scene performed best overall, but ones chosen based on signal-to-noise ratios were seen to be more robust.

Kerekes, John P.↗

Three-Dimensional Turbulent RANS Adjoint-Based Error Correction

Engineering problems commonly require functional outputs of computational fluid dynamics (CFD) simulations with specified accuracy. These simulations are performed with limited computational resources. Computable error estimates offer the possibility of quantifying accuracy on a given mesh and predicting a fine grid functional on a coarser mesh. Such an estimate can be computed by solving the flow equations and the associated adjoint problem for the functional of interest. An adjoint-based error correction procedure is demonstrated for transonic inviscid and subsonic laminar and turbulent flow. A mesh adaptation procedure is formulated to target uncertainty in the corrected functional and terminate when error remaining in the calculation is less than a user-specified error tolerance. This adaptation scheme is shown to yield anisotropic meshes with corrected functionals that are more accurate for a given number of grid points then isotropic adapted and uniformly refined grids.

Park, Michael A.↗

Synoptic scale forecast skill and systematic errors in the MASS 2.0 model

The synoptic scale performance characteristics of MASS 2.0 are determined by comparing filtered 12-24 hr model forecasts to same-case forecasts made by the National Meteorological Center's synoptic-scale Limited-area Fine Mesh model. Characteristics of the two systems are contrasted, and the analysis methodology used to determine statistical skill scores and systematic errors is described. The overall relative performance of the two models in the sample is documented, and important systematic errors uncovered are presented.

Koch, S. E.↗

A Starshade Petal Error Budget for Exo-Earth Detection and Characterization

We present a starshade error budget with engineering requirements that are well within the current manufacturing and metrology capabilities. The error budget is based on an observational scenario in which the starshade spins about its axis on timescales short relative to the zodi-limited integration time, typically several hours. The scatter from localized petal errors is smoothed into annuli around the center of the image plane, resulting in a large reduction in the background flux variation while reducing thermal gradients caused by structural shadowing. Having identified the performance sensitivity to petal shape errors with spatial periods of 3-4 cycles/petal as the most challenging aspect of the design, we have adopted and modeled a manufacturing approach that mitigates these perturbations with 1-meter-long precision edge segments positioned using commercial metrology that readily meets assembly requirements. We have performed detailed thermal modeling and show that the expected thermal deformations are well within the requirements as well. We compare the requirements for four cases: a 32 meter diameter starshade with a 1.5 meter telescope, analyzed at 75 and 90 milliarcseconds, and a 40 meter diameter starshade with a 4 meter telescope, analyzed at 60 and 75 milliarcseconds.

error budget↗

Airborne radar technology for windshear detection

The objectives and accomplishments of the two-and-a-half year effort to describe how returns from on-board Doppler radar are to be used to detect the presence of a wind shear are reported. The problem is modeled as one of first passage in terms of state variables, the state estimates are generated by a bank of extended Kalman filters working in parallel, and the decision strategy involves the use of a voting algorithm for a series of likelihood ratio tests. The performance issue for filtering is addressed in terms of error-covariance reduction and filter divergence, and the performance issue for detection is addressed in terms of using a probability measure transformation to derive theoretical expressions for the error probabilities of a false alarm and a miss.

Hibey, Joseph L.↗

Low power, compact charge coupled device signal processing system

A variety of charged coupled devices (CCDs) for performing programmable correlation for preprocessing environmental sensor data preparatory to its transmission to the ground were developed. A total of two separate ICs were developed and a third was evaluated. The first IC was a CCD chirp z transform IC capable of performing a 32 point DFT at frequencies to 1 MHz. All on chip circuitry operated as designed with the exception of the limited dynamic range caused by a fixed pattern noise due to interactions between the digital and analog circuits. The second IC developed was a 64 stage CCD analog/analog correlator for performing time domain correlation. Multiplier errors were found to be less than 1 percent at designed signal levels and less than 0.3 percent at the measured smaller levels. A prototype IC for performing time domain correlation was also evaluated.

Bosshart, P. W.↗

ACTS 118x Final Report High-Speed TCP Interoperability Testing

With the recent explosion of the Internet and the enormous business opportunities available to communication system providers, great interest has developed in improving the efficiency of data transfer using the Transmission Control Protocol (TCP) of the Internet Protocol (IP) suite. The satellite system providers are interested in solving TCP efficiency problems associated with long delays and error-prone links. Similarly, the terrestrial community is interested in solving TCP problems over high-bandwidth links. Whereas the wireless community is interested in improving TCP performance over bandwidth constrained, error-prone links. NASA realized that solutions had already been proposed for most of the problems associated with efficient data transfer over large bandwidth-delay links (which include satellite links). The solutions are detailed in various Internet Engineering Task Force (IETF) Request for Comments (RFCs). Unfortunately, most of these solutions had not been tested at high-speed (155+ Mbps). Therefore, the NASA's ACTS experiments program initiated a series of TCP experiments to demonstrate scalability of TCP/IP and determine how far the protocol can be optimized over a 622 Mbps satellite link. These experiments were known as the 118i and 118j experiments. During the 118i and 118j experiments, NASA worked closely with SUN Microsystems and FORE Systems to improve the operating system, TCP stacks. and network interface cards and drivers. We were able to obtain instantaneous data throughput rates of greater than 520 Mbps and average throughput rates of 470 Mbps using TCP over Asynchronous Transfer Mode (ATM) over a 622 Mbps Synchronous Optical Network (SONET) OC12 link. Following the success of these experiments and the successful government/industry collaboration, a new series of experiments. the 118x experiments. were developed.

Ivancic, William D.↗

On the probability of undetected error for the maximum distance separable codes

The performance of maximum-distance-separable codes with symbols from GF(1) when they are used for pure error detection or for simultaneous error correction and detection is investigated. These codes are good for symbol error detection. Their probability of undetected error is upper bounded by q to the -r and decreases monotonically as the symbol error probability epsilon decreases from (q-1)/q to 0, where r is the number of parity-check symbols of a code.

Kasami, T.↗

On the probability of undetected error for the maximum distance separable codes

The performance of maximum-distance-separable codes with symbols from GF(1) when they are used for pure error detection or for simultaneous error correction and detection is investigated. These codes are good for symbol error detection. Their probability of undetected error is upper bounded by q to the -r and decreases monotonically as the symbol error probability epsilon decreases from (q-1)/q to 0, where r is the number of parity-check symbols of a code.

Kasami, T.↗

Stochastic response analysis, order reduction, and output feedback controllers for flexible spacecraft

Real disturbances and real sensors have finite bandwidths. The first objective of this paper is to incorporate this finiteness in the 'open-loop modal cost analysis' as applied to a flexible spacecraft. Analysis based on residue calculus shows that among other factors, significance of a mode depends on the power spectral density of disturbances and the response spectral density of sensors at the modal frequency. The second objective of this article is to compare performances of an optimal and a suboptimal output feedback controller, the latter based on 'minimum error excitation' of Kosut. Both the performances are found to be nearly the same, leading us to favor the latter technique because it entails only linear computations. Our final objective is to detect an instability due to truncated modes by representing them as a multiplicative and an additive perturbation in a nominal transfer function. In an example problem it is found that this procedure leads to a narrow range of permissible controller gains, and that it labels a wrong mode as a cause of instability. A free beam is used to illustrate the analysis in this work.

Hablani, H. B.↗

CATS-based Agents That Err

This report describes preliminary research on intelligent agents that make errors. Such agents are crucial to the development of novel agent-based techniques for assessing system safety. The agents extend an agent architecture derived from the Crew Activity Tracking System that has been used as the basis for air traffic controller agents. The report first reviews several error taxonomies. Next, it presents an overview of the air traffic controller agents, then details several mechanisms for causing the agents to err in realistic ways. The report presents a performance assessment of the error-generating agents, and identifies directions for further research. The research was supported by the System-Wide Accident Prevention element of the FAA/NASA Aviation Safety Program.

Callantine, Todd J.↗

An error criterion for determining sampling rates in closed-loop control systems

The determination of an error criterion which will give a sampling rate for adequate performance of linear, time-invariant closed-loop, discrete-data control systems was studied. The proper modelling of the closed-loop control system for characterization of the error behavior, and the determination of an absolute error definition for performance of the two commonly used holding devices are discussed. The definition of an adequate relative error criterion as a function of the sampling rate and the parameters characterizing the system is established along with the determination of sampling rates. The validity of the expressions for the sampling interval was confirmed by computer simulations. Their application solves the problem of making a first choice in the selection of sampling rates.

Brecher, S. M.↗

Survey of Header Compression Techniques

This report provides a summary of several different header compression techniques. The different techniques included are: (1) Van Jacobson's header compression (RFC 1144); (2) SCPS (Space Communications Protocol Standards) header compression (SCPS-TP, SCPS-NP); (3) Robust header compression (ROHC); and (4) The header compression techniques in RFC2507 and RFC2508. The methodology for compression and error correction for these schemes are described in the remainder of this document. All of the header compression schemes support compression over simplex links, provided that the end receiver has some means of sending data back to the sender. However, if that return path does not exist, then neither Van Jacobson's nor SCPS can be used, since both rely on TCP (Transmission Control Protocol). In addition, under link conditions of low delay and low error, all of the schemes perform as expected. However, based on the methodology of the schemes, each scheme is likely to behave differently as conditions degrade. Van Jacobson's header compression relies heavily on the TCP retransmission timer and would suffer an increase in loss propagation should the link possess a high delay and/or bit error rate (BER). The SCPS header compression scheme protects against high delay environments by avoiding delta encoding between packets. Thus, loss propagation is avoided. However, SCPS is still affected by an increased BER (bit-error-rate) since the lack of delta encoding results in larger header sizes. Next, the schemes found in RFC2507 and RFC2508 perform well for non-TCP connections in poor conditions. RFC2507 performance with TCP connections is improved by various techniques over Van Jacobson's, but still suffers a performance hit with poor link properties. Also, RFC2507 offers the ability to send TCP data without delta encoding, similar to what SCPS offers. ROHC is similar to the previous two schemes, but adds additional CRCs (cyclic redundancy check) into headers and improves compression schemes which provide better tolerances in conditions with a high BER.

Ishac, Joseph↗

Modeling and Evaluating Pilot Performance in NextGen: Review of and Recommendations Regarding Pilot Modeling Efforts, Architectures, and Validation Studies

NextGen operations are associated with a variety of changes to the national airspace system (NAS) including changes to the allocation of roles and responsibilities among operators and automation, the use of new technologies and automation, additional information presented on the flight deck, and the entire concept of operations (ConOps). In the transition to NextGen airspace, aviation and air operations designers need to consider the implications of design or system changes on human performance and the potential for error. To ensure continued safety of the NAS, it will be necessary for researchers to evaluate design concepts and potential NextGen scenarios well before implementation. One approach for such evaluations is through human performance modeling. Human performance models (HPMs) provide effective tools for predicting and evaluating operator performance in systems. HPMs offer significant advantages over empirical, human-in-the-loop testing in that (1) they allow detailed analyses of systems that have not yet been built, (2) they offer great flexibility for extensive data collection, (3) they do not require experimental participants, and thus can offer cost and time savings. HPMs differ in their ability to predict performance and safety with NextGen procedures, equipment and ConOps. Models also vary in terms of how they approach human performance (e.g., some focus on cognitive processing, others focus on discrete tasks performed by a human, while others consider perceptual processes), and in terms of their associated validation efforts. The objectives of this research effort were to support the Federal Aviation Administration (FAA) in identifying HPMs that are appropriate for predicting pilot performance in NextGen operations, to provide guidance on how to evaluate the quality of different models, and to identify gaps in pilot performance modeling research, that could guide future research opportunities. This research effort is intended to help the FAA evaluate pilot modeling efforts and select the appropriate tools for future modeling efforts to predict pilot performance in NextGen operations.

pilot human performance models↗

Error analysis of optical correlators

With the growing interest in using binary phase only filters (BPOF) in optical correlators that are implemented on magnetooptic spatial light modulators, an understanding of the effect of errors in system alignment and optical components is critical in obtaining optimal system performance. We present simulations of optical correlator performance degradation in the presence of eight errors. We break these eight errors into three groups: 1) alignment errors, 2) errors due to a combination of component imperfections and alignment errors, and 3) errors which result solely from non-ideal components. Under the first group, we simulate errors in the distance from the object to the first principle plane of the transform lens, the distance from the second principle plane of the transform lens to the filter plane, and rotational misalignment of the input mask with the filter mask. Next we consider errors which result from a combination of alignment and component imperfections. These include errors in the transform lens, the phase compensation lens, and the inverse Fourier transform lens. Lastly we have the component errors resulting from the choice of spatial light modulator. These include contrast error and phase errors caused by the non-uniform flatness of the masks. The effects of each individual error are discussed, and the result of combining all eight errors under assumptions of reasonable tolerances and system parameters is also presented. Conclusions are drawn as to which tolerances are most critical for optimal system performance.

Ma, Paul W.↗

Bayesian estimation - A sensitivity analysis

The robustness of the assigned prior distribution in a Bayesian estimation problem is examined. A Bayesian analysis for a stochastic intensity parameter of a Poisson distribution is summarized in which the natural conjugate is assigned as the prior distribution of the random parameter. The sensitivity analysis is carried out by assuming the existence of a true prior which is different in form from that of the assigned prior distribution. By using mean-squared error as a measure of performance, the ensuing Bayes decision function is compared to the corresponding minimum variance unbiased estimator. Results indicate that the Bayes estimator is largely robust to deviations from the assigned prior and remains squared-error superior to the MVU type within a broad region.

Canavos, G. C.↗