Engineering Papers⌕ Search

SEARCH · Engineering Papers

Results for “bit error rate”

Search indexed NASA NTRS and DOE OSTI research on propulsion, heat transfer, battery materials and energy systems. Follow report and document links to the original sources.

Quote a phrase for an exact phrase match. Source license links do not imply unrestricted reuse.

At least 73 records · Page 4

Performance of the ICAO standard core service modulation and coding techniques

Aviation binary phase shift keying (A-BPSK) is described and simulated performance results are given that demonstrate robust performance in the presence of hardlimiting amplifiers. The performance of coherently-detected A-BPSK with rate 1/2 convolutional coding are given. The performance loss due to the Rician fading was shown to be less than 1 dB over the simulated range. A partially coherent detection scheme that does not require carrier phase recovery was described. This scheme exhibits similiar performance to coherent detection, at high bit error rates, while it is superior at lower bit error rates.

Lodge, John↗

Least Reliable Bits Coding (LRBC) for high data rate satellite communications

An analysis and discussion of a bandwidth efficient multi-level/multi-stage block coded modulation technique called Least Reliable Bits Coding (LRBC) is presented. LRBC uses simple multi-level component codes that provide increased error protection on increasingly unreliable modulated bits in order to maintain an overall high code rate that increases spectral efficiency. Further, soft-decision multi-stage decoding is used to make decisions on unprotected bits through corrections made on more protected bits. Using analytical expressions and tight performance bounds it is shown that LRBC can achieve increased spectral efficiency and maintain equivalent or better power efficiency compared to that of Binary Phase Shift Keying (BPSK). Bit error rates (BER) vs. channel bit energy with Additive White Gaussian Noise (AWGN) are given for a set of LRB Reed-Solomon (RS) encoded 8PSK modulation formats with an ensemble rate of 8/9. All formats exhibit a spectral efficiency of 2.67 = (log2(8))(8/9) information bps/Hz. Bit by bit coded and uncoded error probabilities with soft-decision information are determined. These are traded with with code rate to determine parameters that achieve good performance. The relative simplicity of Galois field algebra vs. the Viterbi algorithm and the availability of high speed commercial Very Large Scale Integration (VLSI) for block codes indicates that LRBC using block codes is a desirable method for high data rate implementations.

Vanderaar, Mark↗

Traveling Wave Tube (TVT) RF Power Combining Demonstration for use in the Jupiter Icy Moons Orbiter (JIMO)

The Jupiter Icy Moons Orbiter (JIMO) is set to launch between the years 2012 and 2015. It will possibly utilize a nuclear reactor power source and ion engines as it travels to the moons of Jupiter. The nuclear reactor will produce hundreds of kilowatts of power for propulsion, communication and various scientific instruments. Hence, the RF amplification devices aboard will be able to operate at a higher power level and data rate. The initial plan for the communications system is for an output of 1000 watts of RF power, a data rate of at least 10 megabits a second, and a frequency of 32 GHz. A higher data rate would be ideal to fully utilize the instruments aboard JIMO. At NASA Glenn, one of our roles in the JIMO project is to demonstrate RF power combining using multiple traveling wave tubes (TWT). In order for the power of separate TWT s to be combined, the RF output waves from each must be in-phase and have the same amplitude. Since different tubes act differently, we had to characterize each tube using a Network Analyzer. We took frequency sweeps and power sweeps to characterize each tube to ensure that they will behave similarly under the same conditions. The 200 watt Dornier tubes had been optimized to run at a lower power level (120 watts) for their extensive use in the ACTS program, so we also had to experiment with adjusting the voltage settings on several internal components (helix, anode, collector) of the tubes to reach the full 200 watt potential. from the ACTS program. Phase shifters and power attenuators were placed in the waveguide circuit at the inputs to the tubes so that adjustments could be made individually to match them exactly. A magic tee was used to route and combine the amplified electromagnetic RF waves on the tube output side. The demonstration of 200 watts of combined power was successful with efficiencies greater than 90% over a 500 MHz bandwidth. The next step will be to demonstrate the use of three amplifiers using two magic tees by adding a 200 watt Dornier tube to the Varian and Logimetrics combined setup for a total of 400 watts. After that we will use two 200 watt Dorniers for 400 watts and eventually four 200 watt Dornier tubes to demonstrate 800 watts. After demonstrating the success of power combining, we will need to verify the integrity of a modulated signal sent through the combined tubes. The purpose will be to see what effects separating and recombining will have on the modulated signal and also what effect it will have on combining efficiency. A Bit Error Rate (BER) will be determined by a Bit Error Rate Tester (BERT) by comparing the random information it transmits to what it receives back. The process began with two 100 watt tubes, a Varian and a Logimetrics, salvaged

Downey, Joseph A.↗

50 Mbps free space direct detection laser diode optical communication system with Q = 4 PPM signaling

A 50 Mbps direct detection optical communication system for use in an intersatellite link was constructed with an AlGaAs laser diode transmitter and a silicon avalanche photodiode photodetector. The system used a Q = 4 PPM format. The receiver consisted of a maximum likelihood PPM detector and a timing recovery subsystem. The PPM slot clock was recovered at the receiver by using a transition detector followed by a PLL. The PPM word clock was recovered by using a second PLL whose input was derived from the presence of back-to-back PPM pulses contained in the received random PPM pulse sequences. The system achieved a bit error rate of 0.000001 at less than 50 detected signal photons/information bit. The receiver was capable of acquiring and maintaining slot and word synchronization for received signal levels greater than 20 photons/information bit, at which the receiver bit error rate was about 0.01.

Sun, Xiaoli↗

Satellite ground-terminal user simulation

Realistic simulation of satellite communication systems and evaluation of satellite networking schemes require emulation of the systems's users. A laboratory model of a Ka-band satellite-switched time-division multiple-access (SS-TDMA) communication network, referred to as the System Integration, Test, and Evaluation (SITE) project, uses special bit-error-rate (BER) test sets to simulate the transmitting and receiving users of a communication network. The bit-error-rate test sets contain circuit boards that can be modified to create a variety of interfaces to satellite system ground terminals.

Shalkhauser, Mary Jo W.↗

A study of the effect of group delay distortion on an SMSK satellite communications channel

The effects of group delay distortion on an SMSK satellite communications channel have been investigated. Software and hardware simulations have been used to determine the effects of channel group delay variations with frequency on the bit error rate for a 220 Mbps SMSK channel. These simulations indicate that group delay distortions can significantly degrade the bit error rate performance. The severity of the degradation is dependent on the amount, type, and spectral location of the group delay distortion.

Kerczewski, Robert J.↗

Performance of concatenated codes using 8-bit and 10-bit Reed-Solomon codes

The performance improvement of concatenated coding systems using 10-bit instead of 8-bit Reed-Solomon codes is measured by simulation. Three inner convolutional codes are considered: (7,1/2), (15,1/4), and (15,1/6). It is shown that approximately 0.2 dB can be gained at a bit error rate of 10(-6). The loss due to nonideal interleaving is also evaluated. Performance comparisons at very low bit error rates may be relevant for systems using data compression.

Pollara, F.↗

Optical multiple access techniques for on-board routing

The purpose of this research contract was to design and analyze an optical multiple access system, based on Code Division Multiple Access (CDMA) techniques, for on board routing applications on a future communication satellite. The optical multiple access system was to effect the functions of a circuit switch under the control of an autonomous network controller and to serve eight (8) concurrent users at a point to point (port to port) data rate of 180 Mb/s. (At the start of this program, the bit error rate requirement (BER) was undefined, so it was treated as a design variable during the contract effort.) CDMA was selected over other multiple access techniques because it lends itself to bursty, asynchronous, concurrent communication and potentially can be implemented with off the shelf, reliable optical transceivers compatible with long term unattended operations. Temporal, temporal/spatial hybrids and single pulse per row (SPR, sometimes termed 'sonar matrices') matrix types of CDMA designs were considered. The design, analysis, and trade offs required by the statement of work selected a temporal/spatial CDMA scheme which has SPR properties as the preferred solution. This selected design can be implemented for feasibility demonstration with off the shelf components (which are identified in the bill of materials of the contract Final Report). The photonic network architecture of the selected design is based on M(8,4,4) matrix codes. The network requires eight multimode laser transmitters with laser pulses of 0.93 ns operating at 180 Mb/s and 9-13 dBm peak power, and 8 PIN diode receivers with sensitivity of -27 dBm for the 0.93 ns pulses. The wavelength is not critical, but 830 nm technology readily meets the requirements. The passive optical components of the photonic network are all multimode and off the shelf. Bit error rate (BER) computations, based on both electronic noise and intercode crosstalk, predict a raw BER of (10 exp -3) when all eight users are communicating concurrently. If better BER performance is required, then error correction codes (ECC) using near term electronic technology can be used. For example, the M(8,4,4) optical code together with Reed-Solomon (54,38,8) encoding provides a BER of better than (10 exp -11). The optical transceiver must then operate at 256 Mb/s with pulses of 0.65 ns because the 'bits' are now channel symbols.

Mendez, Antonio J.↗

Video encoding using adaptive delta modulation

Research work is described that was carried out to develop adaptive delta modulators (ADM) capable of encoding black-and-white and color video signals in the presence of high bit error rates. These were a one-dimensional ADM capable of encoding black-and-white pictures and transmitting digitally encoded voice without increase in bandwidth; an ADM capable of encoding color video signals; and an ADM capable of encoding field-sequential color. For each of these three units, the bit rate could be adjusted within the range from 6 to 24 Mbits/sec. The effects of the bit rate and channel errors on the response of the picture are examined.

Schilling, D. L.↗

Error coding simulations

There are various elements such as radio frequency interference (RFI) which may induce errors in data being transmitted via a satellite communication link. When a transmission is affected by interference or other error-causing elements, the transmitted data becomes indecipherable. It becomes necessary to implement techniques to recover from these disturbances. The objective of this research is to develop software which simulates error control circuits and evaluate the performance of these modules in various bit error rate environments. The results of the evaluation provide the engineer with information which helps determine the optimal error control scheme. The Consultative Committee for Space Data Systems (CCSDS) recommends the use of Reed-Solomon (RS) and convolutional encoders and Viterbi and RS decoders for error correction. The use of forward error correction techniques greatly reduces the received signal to noise needed for a certain desired bit error rate. The use of concatenated coding, e.g. inner convolutional code and outer RS code, provides even greater coding gain. The 16-bit cyclic redundancy check (CRC) code is recommended by CCSDS for error detection.

Noble, Viveca K.↗

Performance analysis of a cascaded coding scheme with interleaved outer code

A cascaded coding scheme for a random error channel with a bit-error rate is analyzed. In this scheme, the inner code C sub 1 is an (n sub 1, m sub 1l) binary linear block code which is designed for simultaneous error correction and detection. The outer code C sub 2 is a linear block code with symbols from the Galois field GF (2 sup l) which is designed for correcting both symbol errors and erasures, and is interleaved with a degree m sub 1. A procedure for computing the probability of a correct decoding is presented and an upper bound on the probability of a decoding error is derived. The bound provides much better results than the previous bound for a cascaded coding scheme with an interleaved outer code. Example schemes with inner codes ranging from high rates to very low rates are evaluated. Several schemes provide extremely high reliability even for very high bit-error rates say 10 to the -1 to 10 to the -2 power.

Lin, S.↗

The advanced receiver 2: Telemetry test results in CTA 21

Telemetry tests with the Advanced Receiver II (ARX II) in Compatibility Test Area 21 are described. The ARX II was operated in parallel with a Block-III Receiver/baseband processor assembly combination (BLK-III/BPA) and a Block III Receiver/subcarrier demodulation assembly/symbol synchronization assembly combination (BLK-III/SDA/SSA). The telemetry simulator assembly provided the test signal for all three configurations, and the symbol signal to noise ratio as well as the symbol error rates were measured and compared. Furthermore, bit error rates were also measured by the system performance test computer for all three systems. Results indicate that the ARX-II telemetry performance is comparable and sometimes superior to the BLK-III/BPA and BLK-III/SDA/SSA combinations.

Hinedi, S.↗

Architecture of the TELEDESIC satellite system

There is a significant worldwide demand for broadband communications capacity. Teledesic plans to meet this demand using a constellation of 924 low-Earth orbit (LEO) satellites operating in Ka-band (30/20 GHz). The Teledesic network will provide 'fiber-like' service quality, including low transmission delay, high data rates, and low bit error rates, to fixed and mobile users around the world starting in 2001.

Sturza, Mark A.↗

Design of communication systems using short-constraint-length convolutional codes.

A method is presented for calculating the effect of carrier-phase reference error in a receiver phase-locked loop on bit error rates in convolutionally coded data, for the practical design of systems using short-constraint-length convolutional codes. A set of design curves shows the relation between design bit error rate, uplink carrier tracking loop SNR, downlink total SNR, and downlink modulation index. These curves make possible rapid and simple system optimization.

Merrill, H. M.↗

High-order neural models for error correcting code

The decoding and error-correction of data transmitted over a noisy channel is in principle equivalent to the operation of a neural network performing as a content-addressable memory. For a successful application, however, the neural network has to be capable of storing arbitrary words, and it has to be guaranteed that the stored words represent the only stable attractors of the memory. This paper presents a novel high-order neural network architecture that has these characteristics. The analog nature of the network can be used to perform soft-decision decoding with any block code. The performance in terms of postdecoding bit error rate versus SNR is demonstrated for two exemplary block codes. The comparison with a conventional decoding algorithm for a (15,5) cyclic redundancy code shows, for example, that the bit error rate at 7dB SNR can be decreased by two orders of magnitude.

Jeffries, Clark↗

Survey of Header Compression Techniques

This report provides a summary of several different header compression techniques. The different techniques included are: (1) Van Jacobson's header compression (RFC 1144); (2) SCPS (Space Communications Protocol Standards) header compression (SCPS-TP, SCPS-NP); (3) Robust header compression (ROHC); and (4) The header compression techniques in RFC2507 and RFC2508. The methodology for compression and error correction for these schemes are described in the remainder of this document. All of the header compression schemes support compression over simplex links, provided that the end receiver has some means of sending data back to the sender. However, if that return path does not exist, then neither Van Jacobson's nor SCPS can be used, since both rely on TCP (Transmission Control Protocol). In addition, under link conditions of low delay and low error, all of the schemes perform as expected. However, based on the methodology of the schemes, each scheme is likely to behave differently as conditions degrade. Van Jacobson's header compression relies heavily on the TCP retransmission timer and would suffer an increase in loss propagation should the link possess a high delay and/or bit error rate (BER). The SCPS header compression scheme protects against high delay environments by avoiding delta encoding between packets. Thus, loss propagation is avoided. However, SCPS is still affected by an increased BER (bit-error-rate) since the lack of delta encoding results in larger header sizes. Next, the schemes found in RFC2507 and RFC2508 perform well for non-TCP connections in poor conditions. RFC2507 performance with TCP connections is improved by various techniques over Van Jacobson's, but still suffers a performance hit with poor link properties. Also, RFC2507 offers the ability to send TCP data without delta encoding, similar to what SCPS offers. ROHC is similar to the previous two schemes, but adds additional CRCs (cyclic redundancy check) into headers and improves compression schemes which provide better tolerances in conditions with a high BER.

Ishac, Joseph↗

Reception of Multiple Telemetry Signals via One Dish Antenna

A microwave aeronautical-telemetry receiver system includes an antenna comprising a seven-element planar array of receiving feed horns centered at the focal point of a paraboloidal dish reflector that is nominally aimed at a single aircraft or at multiple aircraft flying in formation. Through digital processing of the signals received by the seven feed horns, the system implements a method of enhanced cancellation of interference, such that it becomes possible to receive telemetry signals in the same frequency channel simultaneously from either or both of two aircraft at slightly different angular positions within the field of view of the antenna, even in the presence of multipath propagation. The present system is an advanced version of the system described in Spatio- Temporal Equalizer for a Receiving-Antenna Feed Array NPO-43077, NASA Tech Briefs, Vol. 34, No. 2 (February 2010), page 32. To recapitulate: The radio-frequency telemetry signals received by the seven elements of the array are digitized, converted to complex baseband form, and sent to a spatio-temporal equalizer that consists mostly of a bank of seven adaptive finite-impulse-response (FIR) filters (one for each element in the array) plus a unit that sums the outputs of the filters. The combination of the spatial diversity of the feedhorn array and the temporal diversity of the filter bank affords better multipath suppression performance than is achievable by means of temporal equalization alone. The FIR filter bank adapts itself in real time to enable reception of telemetry at a low bit error rate, even in the presence of frequency-selective multipath propagation like that commonly found at flight-test ranges. The combination of the array and the filter bank makes it possible to constructively add multipath incoming signals to the corresponding directly arriving signals, thereby enabling reductions in telemetry bit-error rates.

Mukai, Ryan↗

The effect of noisy carrier reference on telemetry with baseband arraying

Imperfect carrier reference causes a degradation in detection performance in coherent communication systems. A measure of this degradation is the radio loss, which is the amount of increase in data signal to noise ratio (SNR) per bit required to achieve the same bit error rate when carrier reference is perfect. Performance analysis and numerical results are obtained for the Voyager high rate telemetry link with maximum likelihood convolutional decoding. The arraying of antennas provides not only improved performance due to an increase in effective antenna aperture, but also a decrease in radio loss with respect to a single antenna. This telemetry link performance improvement is a function of the carrier loop SNR and data bit error rate. When the carrier loop SNR's are low, it provides a significant improvement in the telemetry link performance since the decrease in radio loss with respect to a single station is substantial.

Divsalar, D.↗