Engineering Papers⌕ Search

SEARCH · Engineering Papers

Results for “error propagation”

Search indexed NASA NTRS and DOE OSTI research on propulsion, heat transfer, battery materials and energy systems. Follow report and document links to the original sources.

Quote a phrase for an exact phrase match. Source license links do not imply unrestricted reuse.

At least 325 records · Page 18

Survey of Header Compression Techniques

This report provides a summary of several different header compression techniques. The different techniques included are: (1) Van Jacobson's header compression (RFC 1144); (2) SCPS (Space Communications Protocol Standards) header compression (SCPS-TP, SCPS-NP); (3) Robust header compression (ROHC); and (4) The header compression techniques in RFC2507 and RFC2508. The methodology for compression and error correction for these schemes are described in the remainder of this document. All of the header compression schemes support compression over simplex links, provided that the end receiver has some means of sending data back to the sender. However, if that return path does not exist, then neither Van Jacobson's nor SCPS can be used, since both rely on TCP (Transmission Control Protocol). In addition, under link conditions of low delay and low error, all of the schemes perform as expected. However, based on the methodology of the schemes, each scheme is likely to behave differently as conditions degrade. Van Jacobson's header compression relies heavily on the TCP retransmission timer and would suffer an increase in loss propagation should the link possess a high delay and/or bit error rate (BER). The SCPS header compression scheme protects against high delay environments by avoiding delta encoding between packets. Thus, loss propagation is avoided. However, SCPS is still affected by an increased BER (bit-error-rate) since the lack of delta encoding results in larger header sizes. Next, the schemes found in RFC2507 and RFC2508 perform well for non-TCP connections in poor conditions. RFC2507 performance with TCP connections is improved by various techniques over Van Jacobson's, but still suffers a performance hit with poor link properties. Also, RFC2507 offers the ability to send TCP data without delta encoding, similar to what SCPS offers. ROHC is similar to the previous two schemes, but adds additional CRCs (cyclic redundancy check) into headers and improves compression schemes which provide better tolerances in conditions with a high BER.

Ishac, Joseph↗

Predicting The Propagation Of Cracks

Advanced Crack Propagation Predictive Analysis Program, FLAGR04, developed as aid in predicting growth of preexisting flaws and cracks in structural components. Provides fracture-mechanics analyst with computerized method of evaluation of "safe crack-growth life" capabilities of structural components. Also used to evaluate tolerance-to-damage aspects of given structural design. Predicts growth of crack by use of two-dimensional model independently predicting growth of flaw in two directions based on calculation of stress-intensity factors. Input to FLAGR04 consists of initial definition of crack, type of rate solution, type and geometry of flaw, properties of material, data on load spectrum, load-stress functions, and design-limit stress levels. Output includes echo of input with any error or warning message and history of propagation of crack. Written in FORTRAN IV.

Tianlai, HU↗

A transition matrix approach to the Davenport gryo calibration scheme

The in-flight gyro calibration scheme commonly used by NASA Goddard Space Flight Center (GSFC) attitude ground support teams closely follows an original version of the Davenport algorithm developed in the late seventies. Its basic idea is to minimize the least-squares differences between attitudes gyro- propagated over the course of a maneuver and those determined using post- maneuver sensor measurements. The paper represents the scheme in a recursive form by combining necessary partials into a rectangular matrix, which is propagated in exactly the same way as a Kalman filters square transition matrix. The nontrivial structure of the propagation matrix arises from the fact that attitude errors are not included in the state vector, and therefore their derivatives with respect to estimated a parameters do not appear in the transition matrix gyro defined in the conventional way. In cases when the required accuracy can be achieved by a single iteration, representation of the Davenport gyro calibration scheme in a recursive form allows one to discard each gyro measurement immediately after it was used to propagate the attitude and state transition matrix. Another advantage of the new approach is that it utilizes the same expression for the error sensitivity matrix as that used by the Kalman filter. As a result the suggested modification of the Davenport algorithm made it possible to reuse software modules implemented in the Kalman filter estimator, where both attitude errors and gyro calibration parameters are included in the state vector. The new approach has been implemented in the ground calibration utilities used to support the Tropical Rainfall Measuring Mission (TRMM). The paper analyzes some preliminary results of gyro calibration performed by the TRMM ground attitude support team. It is demonstrated that an effect of the second iteration on estimated values of calibration parameters is negligibly small, and therefore there is no need to store processed gyro data. This opens a promising opportunity for onboard implementation of the suggested recursive procedure by combining, it with the Kalman filter used to obtain necessary attitude solutions at the beginning and end of each maneuver.

Natanson, G. A.↗

Consistency and convergence for numerical radiation conditions

The problem of imposing radiation conditions at artificial boundaries for the numerical simulation of wave propagation is considered. Emphasis is on the behavior and analysis of the error which results from the restriction of the domain. The theory of error estimation is briefly outlined for boundary conditions. Use is made of the asymptotic analysis of propagating wave groups to derive and analyze boundary operators. For dissipative problems this leads to local, accurate conditions, but falls short in the hyperbolic case. A numerical experiment on the solution of the wave equation with cylindrical symmetry is described. A unified presentation of a number of conditions which have been proposed in the literature is given and the time dependence of the error which results from their use is displayed. The results are in qualitative agreement with theoretical considerations. It was found, however, that for this model problem it is particularly difficult to force the error to decay rapidly in time.

Hagstrom, Thomas↗

Land mobile satellite propagation measurements in Japan using ETS-V satellite

Propagation characteristics of land mobile satellite communications channels have been investigated actively in recent years. Information of propagation characteristics associated with multipath fading and shadowing is required to design commercial land mobile satellite communications systems, including protocol and error correction method. CRL (Communications Research Laboratory) has carried out propagation measurements using the Engineering Test Satellite-V (ETS-V) at L band (1.5 GHz) through main roads in Japan by a medium gain antenna with an autotracking capability. This paper presents the propagation statistics obtained in this campaign.

Obara, Noriaki↗

A Factored Implicit Scheme for Numerical Weather Prediction with Small Factorization Error

Numerical results show that, for large time steps, the factorization error can be significant, even for the slowly propagating Rossby modes. A new scheme is formulated based on a more accurate factorization of the equations. By grouping separately the terms of the equations which give rise to the fast and slow motion, the equations are factored more accurately. The fast-slow factorization eliminated the factorization error. If each of the fast and slow factors are factored again according to spatial components, the resulting scheme only involves the solution of one dimensional linear systems, and computational efficient. It is shown that the factorization error for the slow made component is negligible for this new scheme.

Augenbaum, J. M.↗

Spectral solution of acoustic wave-propagation problems

The Chebyshev spectral collocation solution of acoustic wave propagation problems is considered. It is shown that the phase errors decay exponentially fast and that the number of points per wavelength is not sufficient to estimate the phase accuracy. Applications include linear propagation of a sinusoidal acoustic wavetrain in two space dimensions, and the interaction of a sound wave with the bow shock formed by placing a cylinder in a uniform Mach 4 supersonic free stream.

Kopriva, David A.↗

An algorithm for propagating the square-root covariance matrix in triangular form

A method for propagating the square root of the state error covariance matrix in lower triangular form is described. The algorithm can be combined with any triangular square-root measurement update algorithm to obtain a triangular square-root sequential estimation algorithm. The triangular square-root algorithm compares favorably with the conventional sequential estimation algorithm with regard to computation time.

Tapley, B. D.↗

A Case Study of the Impact of AIRS Temperature Retrievals on Numerical Weather Prediction

Large errors in numerical weather prediction are often associated with explosive cyclogenesis. Most studes focus on the under-forecasting error, i.e. cases of rapidly developing cyclones which are poorly predicted in numerical models. However, the over-forecasting error (i.e., to predict an explosively developing cyclone which does not occur in reality) is a very common error that severely impacts the forecasting skill of all models and may also present economic costs if associated with operational forecasting. Unnecessary precautions taken by marine activities can result in severe economic loss. Moreover, frequent occurrence of over-forecasting can undermine the reliance on operational weather forecasting. Therefore, it is important to understand and reduce the prdctions of extreme weather associated with explosive cyclones which do not actually develop. In this study we choose a very prominent case of over-forecasting error in the northwestern Pacific. A 960 hPa cyclone develops in less than 24 hour in the 5-day forecast, with a deepening rate of about 30 hPa in one day. The cyclone is not versed in the analyses and is thus a case of severe over-forecasting. By assimilating AIRS data, the error is largely eliminated. By following the propagation of the anomaly that generates the spurious cyclone, it is found that a small mid-tropospheric geopotential height negative anomaly over the northern part of the Indian subcontinent in the initial conditions, propagates westward, is amplified by orography, and generates a very intense jet streak in the subtropical jet stream, with consequent explosive cyclogenesis over the Pacific. The AIRS assimilation eliminates this anomaly that may have been caused by erroneous upper-air data, and represents the jet stream more correctly. The energy associated with the jet is distributed over a much broader area and as a consequence a multiple, but much more moderate cyclogenesis is observed.

Reale, O.↗

Optics Program Simplifies Analysis and Design

Engineers at Goddard Space Flight Center partnered with software experts at Mide Technology Corporation, of Medford, Massachusetts, through a Small Business Innovation Research (SBIR) contract to design the Disturbance-Optics-Controls-Structures (DOCS) Toolbox, a software suite for performing integrated modeling for multidisciplinary analysis and design. The DOCS Toolbox integrates various discipline models into a coupled process math model that can then predict system performance as a function of subsystem design parameters. The system can be optimized for performance; design parameters can be traded; parameter uncertainties can be propagated through the math model to develop error bounds on system predictions; and the model can be updated, based on component, subsystem, or system level data. The Toolbox also allows the definition of process parameters as explicit functions of the coupled model and includes a number of functions that analyze the coupled system model and provide for redesign. The product is being sold commercially by Nightsky Systems Inc., of Raleigh, North Carolina, a spinoff company that was formed by Mide specifically to market the DOCS Toolbox. Commercial applications include use by any contractors developing large space-based optical systems, including Lockheed Martin Corporation, The Boeing Company, and Northrup Grumman Corporation, as well as companies providing technical audit services, like General Dynamics Corporation

Source record↗

A 10-Year Comparison of Water Levels Measured with a Geodetic GPS Receiver Versus a Conventional Tide Gauge

A standard geodetic GPS receiver and a conventional Aquatrak tide gauge, collocated at Friday Harbor, Washington, are used to assess the quality of 10 years of water levels estimated from GPS sea surface reflections.The GPS results are improved by accounting for (tidal) motion of the reflecting sea surface and for signal propagation delay by the troposphere. The RMS error of individual GPS water level estimates is about 12 cm. Lower water levels are measured slightly more accurately than higher water levels. Forming daily mean sea levels reduces the RMS difference with the tide gauge data to approximately 2 cm. For monthly means, the RMS difference is 1.3 cm. The GPS elevations, of course, can be automatically placed into a well-defined terrestrial reference frame. Ocean tide coefficients, determined from both the GPS and tide gauge data, are in good agreement, with absolute differences below 1 cm for all constituents save K1 and S1. The latter constituent is especially anomalous, probably owing to daily temperature-induced errors in the Aquatrak tide gauge

Larson, Kristine M.↗

Measurement of birefringence for optical recording disk substrates

The birefringence of bare and coated substrates for magneto-optical recording is experimentally investigated using ellipsometry at the wavelengths of 632.8 nm and 780 nm. The rotation and ellipticity of the polarization state of the reflected or transmitted light is measured for different incident angles and different orientations of the incident linear polarization. The measured data is then fitted by a computer program which solves the Maxwell equations for the plane-wave propagation in a multilayer structure and minimizes the error between the measured and calculated data by adjusting the unknown parameters of the multilayer. This approach enables us to determine orientations of the three principal axes in the substrate and the corresponding refractive indices. A special feature of our ellipsometers is that a glass hemisphere is placed in contact with the substrate, which eliminates the refraction of the incident light and enables a maximum propagation angle of 70 degrees (with respect to the normal) in the substrate. This increases the sensitivity of the measurement. Certain anomalies were observed, which we believe are associated with the presence of grooves on these substrates.

Fu, Hong↗

Automating Surface Attitude Positioning and Pointing Operations for Mars 2020

The Surface Attitude Positioning and Pointing (SAPP) subsystem of the Mars Perseverance rover keeps track of the rover’s position and attitude on the surface of Mars. The SAPP Downlink Engineering Operations team members receive data from the rover on a daily basis. They must interpret the data to make sure the rover is staying safe and to support uplink planning. The SAPP team keeps track of the error growth in the rover’s attitude estimate due to noise in the Rover Inertial Measurement Unit’s (RIMU) gyroscopes used to propagate that attitude estimate whenever the rover is moving. Whenever this error grows to a particular threshold, SAPP is responsible for updating the onboard attitude knowledge using the RIMU’s accelerometers to estimate rover roll and pitch and sun imaging to estimate rover yaw, thereby reducing this attitude estimation error. Accurate attitude estimation is required so that the rover can successfully point its High Gain Antenna (HGA) to receive information from Earth and as a backup to the Mars orbiters used for sending data from the rover to Earth, point instruments on its Remote Sensing Mast (RSM), and support safe movement and placement of instruments by the rover’s ARM relative to the Martian surface. The Mars 2020 Engineering Operations team has been working to increase the operational efficiency of the mission and eventually move to a five-hour timeline for daily operations. In pursuit of this goal, the SAPP Engineering Operations team has automated their downlink process by developing a centralized Jupyter notebook to analyze the data received daily from the rover. The SAPP downlink Jupyter notebook automatically collects the data relevant to the SAPP subsystem and visualizes this information in plots and tables that can be easily read by downlink operators to aid them in assessing the status of the subsystem. Various Application Programming Interfaces (APIs) have been incorporated into the downlink daily notebook to automate the collection and posting of data, such as gathering and posting data products to the cloud. The SAPP team has also developed a SAPP downlink software library that includes functions to aid the notebook in processing data. In addition to assessing the SAPP subsystem on a daily basis, operators need to assess the long-term trending behavior of the subsystem over time. An automated trending process has been developed to collect information from the daily notebooks in order to plot and analyze that data in a centralized place. These daily and trending processes have expedited the SAPP downlink assessment and laid the groundwork to completely automate the SAPP downlink process so that SAPP operators are unnecessary unless something unexpected occurs. This paper will provide an overview of the functions that the SAPP subsystem carries out on a daily basis, and will then dive into the automations that have been developed for daily and trending downlink assessment. An assessment of the downlink efficiency will be provided, along with a summary of lessons learned and work to go. Finally, the authors will discuss how these types of automated spacecraft health assessments could be more broadly used within mission operations.

Zarifian, Anais↗

Data vs. information: A system paradigm

The data system designer requires data parameters, and is dependent on the user to convert information needs to these data parameters. This conversion will be done with more or less accuracy, beginning a chain of inaccuracies which propagate through the system, and which, in the end, may prevent the user from converting the data received into the information required. The concept to be pursued is that errors occur in various parts of the system, and, having occurred, propagate to the end. Modeling of the system may allow an estimation of the effects at any point and the final accumulated effect, and may prove a method of allocating an error budget among the system components. The selection of the various technical parameters which a data system must meet must be done in relation to the ability of the user to turn the cold, impersonal data into a live, personal decision or piece of information.

Billingsley, F. C.↗

Performance of coded MFSK in a Rician fading channel

The performance of convolutional codes in conjunction with noncoherent multiple frequency shift-keyed (MFSK) modulation and Viterbi maximum likelihood decoding on a Rician fading channel is examined in detail. While the primary motivation underlying this work has been concerned with system performance on the planetary entry channel, it is expected that the results are of considerably wider interest. Particular attention is given to modeling the channel in terms of a few meaningful parameters which can be correlated closely with the results of theoretical propagation studies. Fairly general upper bounds on bit error probability performance in the presence of fading are derived and compared with simulation results using both unquantized and quantized receiver outputs. The effects of receiver quantization and channel memory are investigated and it is concluded that the coded noncoherent MFSK system offers an attractive alternative to coherent BPSK in providing reliable low data rate communications in fading channels typical of planetary entry missions.

Modestino, J. W.↗