Engineering Papers⌕ Search

SEARCH · Engineering Papers

Results for “data compression techniques”

Search indexed NASA NTRS and DOE OSTI research on propulsion, heat transfer, battery materials and energy systems. Follow report and document links to the original sources.

Quote a phrase for an exact phrase match. Source license links do not imply unrestricted reuse.

At least 271 records · Page 15

Numerical and approximate solution of the high Reynolds number small separation problem

Several possible methods of solving the small separation problem at high Reynolds number are investigated. In addition to using analytical methods, there are several numerical approaches which are used. High Reynolds number laminar two dimensional problems are used for simplicity. A brief discussion is given of the finite difference methods since these methods are discussed in detail. Most of the emphasis is placed on developing an approximate integral method. As a model problem the supersonic compression ramp problem is chosen since several numerical solutions along with experimental data are available. The techniques discussed are modified and applied to other similar type wall geometries.

Davis, R. T.↗

A Composite Damage Tolerance Simulation Technique to Augment the Building Block Approach

Aerospace structures comprised of composite materials are traditionally certified empirically via the Building Block Approach (BBA). While this approach has been performed successfully in the past, it is expensive and time-consuming. One means to improve the overall efficiency of composite structural certification is to reduce the cost of the BBA by eliminating the need for some tests by incorporating damage analysis tools. For an analysis to replace a given test, the tool must first be validated using other similar test data. The subject of this paper is a description of an efficient analysis technique for simulating compression after damage strength of a solid laminate. The analysis technique is one that is practical for use in an applied engineering context due to efforts to minimize necessary computational resources and complexity of the model.

McElroy, Mack↗

Bit-wise arithmetic coding for data compression

This article examines the problem of compressing a uniformly quantized independent and identically distributed (IID) source. We present a new compression technique, bit-wise arithmetic coding, that assigns fixed-length codewords to the quantizer output and uses arithmetic coding to compress the codewords, treating the codeword bits as independent. We examine the performance of this method and evaluate the overhead required when used block-adaptively. Simulation results are presented for Gaussian and Laplacian sources. This new technique could be used as the entropy coder in a transform or subband coding system.

Kiely, A. B.↗

Measurement of apparent thermal conductivity of multilayer insulations at low compressive loads.

A description is presented of the test calorimeter, the experimental technique, and the results obtained in an evaluation of four multilayer insulations selected for application on future multilaunch space vehicles utilizing liquid hydrogen and oxygen for orbital operations. Particular attention is paid to techniques for minimizing error in obtaining thermal conductivity data. The effective conductivity for four high-performance insulations was determined at a minimum of four compressive loads in the range from 0.0001 to 0.1 psi. Results show that the thermal conductivity of multilayer insulations is insensitive to small changes in mechanical loading at 1 torr interstitial gas pressure, but becomes increasingly more sensitive to mechanical loading as the interstitial gas pressure is reduced.

Holmes, V. L.↗

Dynamic measurements of gear tooth friction and load

As part of a program to study fundamental mechanisms of gear noise, static and dynamic gear tooth strain measurements were made on the NASA gear-noise rig. Tooth-fillet strains from low-contact ratio-spur gears were recorded for 28 operating conditions. A method is introduced whereby strain gage measurements taken from both the tension and compression sides of a gear tooth can be transformed into the normal and frictional loads on the tooth. This technique was applied to both the static and dynamic strain data. The static case results showed close agreement with expected results. For the dynamic case, the normal-force computation produced very good results, but the friction results, although promising, were not as accurate. Tooth sliding friction strongly affected the signal from the strain gage on the tensionside of the tooth. The compression gage was affected by friction to a much lesser degree. The potential of the method to measure friction force was demonstrated, but further refinement will be required before this technique can be used to measure friction forces dynamically with an acceptable degree of accuracy.

Rebbechi, Brian↗

Image registration using binary boundary maps

Registration technique that matches binary boundary maps extracted from raw data, rather than matching actual data, is considerably faster than other techniques. Boundary maps, which are digital representations of regions where image amplitudes change significantly, typically represent data compression of 60 to 70 percent. Maps allow average products to be computed with addition rather than multiplication, further reducing computation time.

Andrus, J. F.↗

Noiseless coding for the Gamma Ray spectrometer

The payload of several future unmanned space missions will include a sophisticated gamma ray spectrometer. Severely constrained data rates during certain portions of these missions could limit the possible science return from this instrument. This report investigates the application of universal noiseless coding techniques to represent gamma ray spectrometer data more efficiently without any loss in data integrity. Performance results demonstrate compression factors from 2.5:1 to 20:1 in comparison to a standard representation. Feasibility was also demonstrated by implementing a microprocessor breadboard coder/decoder using an Intel 8086 processor.

Rice, R.↗

A structural-stochastic model for the analysis and synthesis of cloud images

A structural-stochastic image model is developed for the analysis and synthesis of cloud images. The ability of the model to characterize the visual appearance of cloud fields observed by satellite with a limited number of parameters is demonstrated. The model merges structural and stochastic information, the stochastic model acting as a local statistical operator applied to the output of the structural model. The structural or large-scale organization of the scene is retrieved from the two-dimensional Fourier representation of the digital image. The pattern generated by the major Fourier components provides a first guess of the scene. The stochastic aspect is described by a Markov model of texture that assumes a binomial probability distribution for the local grey-level variability. This Markov model provides four parameters that represent the clustering strength in the horizontal, vertical and diagonal directions. These parameters are estimated by a standard maximum-likelihood technique. The image can be reproduced with a fair degree of verisimilitude from these parameters. The data compression factor is of the order of one hundred to several hundreds.

Garand, L.↗

Flow quality measurements in compressible subsonic flows

The purpose is to re-examine the heat transfer from a hot-wire probe in the compressible subsonic flow regime; describe the three-wire hot-wire probe calibration and data reduction techniques used to measure the velocity, density, and total temperature fluctuation; and present flow quality results obtained in the Langley 0.3 meter Transonic Cryogenic Wind Tunnel and in flight with the NASA JetStar from the same three-wire hot-wire probe.

Stainback, P. Calvin↗

Schlieren Imaging Of An Aircraft In Flight

Technique for making schlieren images of airplanes and missiles in supersonic flight devised to help understand physics of compressible aerodynamic flows about complicated aircraft shapes. Technique also used to study far-field sonic booms. Data obtained from schlieren images useful in optimizing designs of prototype aircraft. Technique incorporates elements of focusing schlieren photography, astronomical photography, and streak photography. Using sun or moon as source of light, apparatus forms image revealing gradients of density in air flow.

Weinstein, Leonard M.↗

Optical storage media data integrity studies

Optical disk-based information systems are being used in private industry and many Federal Government agencies for on-line and long-term storage of large quantities of data. The storage devices that are part of these systems are designed with powerful, but not unlimited, media error correction capacities. The integrity of data stored on optical disks does not only depend on the life expectancy specifications for the medium. Different factors, including handling and storage conditions, may result in an increase of medium errors in size and frequency. Monitoring the potential data degradation is crucial, especially for long term applications. Efforts are being made by the Association for Information and Image Management Technical Committee C21, Storage Devices and Applications, to specify methods for monitoring and reporting to the user medium errors detected by the storage device while writing, reading or verifying the data stored in that medium. The Computer Systems Laboratory (CSL) of the National Institute of Standard and Technology (NIST) has a leadership role in the development of these standard techniques. In addition, CSL is researching other data integrity issues, including the investigation of error-resilient compression algorithms. NIST has conducted care and handling experiments on optical disk media with the objective of identifying possible causes of degradation. NIST work in data integrity and related standards activities is described.

Podio, Fernando L.↗

Measurements of Unsteady Vortex Flowfields

A combined surface hot film and laser velocimeter measurement technique has been developed for the study of time-dependent turbulent flows. Data obtained in a compressible cylinder wake (M(sub infinity) = 0.6) are presented, and its structure in both the Eulerian and Lagrangian frames is discussed. Turbulence data obtained by conventional and phase averaging of the velocity fluctuations provide details of the small- and large-scale contributions to the total turbulent field.

Owen, F. K.↗

Survey of Header Compression Techniques

This report provides a summary of several different header compression techniques. The different techniques included are: (1) Van Jacobson's header compression (RFC 1144); (2) SCPS (Space Communications Protocol Standards) header compression (SCPS-TP, SCPS-NP); (3) Robust header compression (ROHC); and (4) The header compression techniques in RFC2507 and RFC2508. The methodology for compression and error correction for these schemes are described in the remainder of this document. All of the header compression schemes support compression over simplex links, provided that the end receiver has some means of sending data back to the sender. However, if that return path does not exist, then neither Van Jacobson's nor SCPS can be used, since both rely on TCP (Transmission Control Protocol). In addition, under link conditions of low delay and low error, all of the schemes perform as expected. However, based on the methodology of the schemes, each scheme is likely to behave differently as conditions degrade. Van Jacobson's header compression relies heavily on the TCP retransmission timer and would suffer an increase in loss propagation should the link possess a high delay and/or bit error rate (BER). The SCPS header compression scheme protects against high delay environments by avoiding delta encoding between packets. Thus, loss propagation is avoided. However, SCPS is still affected by an increased BER (bit-error-rate) since the lack of delta encoding results in larger header sizes. Next, the schemes found in RFC2507 and RFC2508 perform well for non-TCP connections in poor conditions. RFC2507 performance with TCP connections is improved by various techniques over Van Jacobson's, but still suffers a performance hit with poor link properties. Also, RFC2507 offers the ability to send TCP data without delta encoding, similar to what SCPS offers. ROHC is similar to the previous two schemes, but adds additional CRCs (cyclic redundancy check) into headers and improves compression schemes which provide better tolerances in conditions with a high BER.

Ishac, Joseph↗

Loading tests of a wing structure for a hypersonic aircraft

Room-temperature loading tests were conducted on a wing structure designed with a beaded panel concept for a Mach 8 hypersonic research airplane. Strain, stress, and deflection data were compared with the results of three finite-element structural analysis computer programs and with design data. The test program data were used to evaluate the structural concept and the methods of analysis used in the design. A force stiffness technique was utilized in conjunction with load conditions which produced various combinations of panel shear and compression loading to determine the failure envelope of the buckling critical beaded panels The force-stiffness data did not result in any predictions of buckling failure. It was, therefore, concluded that the panels were conservatively designed as a result of design constraints and assumptions of panel eccentricities. The analysis programs calculated strains and stresses competently. Comparisons between calculated and measured structural deflections showed good agreement. The test program offered a positive demonstration of the beaded panel concept subjected to room-temperature load conditions.

Fields, R. A.↗

A recursive technique for adaptive vector quantization

Vector Quantization (VQ) is fast becoming an accepted, if not preferred method for image compression. The VQ performs well when compressing all types of imagery including Video, Electro-Optical (EO), Infrared (IR), Synthetic Aperture Radar (SAR), Multi-Spectral (MS), and digital map data. The only requirement is to change the codebook to switch the compressor from one image sensor to another. There are several approaches for designing codebooks for a vector quantizer. Adaptive Vector Quantization is a procedure that simultaneously designs codebooks as the data is being encoded or quantized. This is done by computing the centroid as a recursive moving average where the centroids move after every vector is encoded. When computing the centroid of a fixed set of vectors the resultant centroid is identical to the previous centroid calculation. This method of centroid calculation can be easily combined with VQ encoding techniques. The defined quantizer changes after every encoded vector by recursively updating the centroid of minimum distance which is the selected by the encoder. Since the quantizer is changing definition or states after every encoded vector, the decoder must now receive updates to the codebook. This is done as side information by multiplexing bits into the compressed source data.

Lindsay, Robert A.↗

Data compression for satellite images

An efficient data compression system is presented for satellite pictures and two grey level pictures derived from satellite pictures. The compression techniques take advantages of the correlation between adjacent picture elements. Several source coding methods are investigated. Double delta coding is presented and shown to be the most efficient. Both predictive differential quantizing technique and double delta coding can be significantly improved by applying a background skipping technique. An extension code is constructed. This code requires very little storage space and operates efficiently. Simulation results are presented for various coding schemes and source codes.

Chen, P. H.↗

Test/semi-empirical analysis of a carbon/epoxy fabric stiffened panel

The purpose of this work-in-progress is to present a semi-empirical analysis method developed to predict the buckling and crippling loads of carbon/epoxy fabric blade stiffened panels in compression. This is a hand analysis method comprised of well known, accepted techniques, logical engineering judgements, and experimental data that results in conservative solutions. In order to verify this method, a stiffened panel was fabricated and tested. Both the best and analysis results are presented.

Spier, E. E.↗